Air 2 controller/app not communicating?

Any DJI support experts here?

Flew yesterday (Air2, iPhone 11) no issues. This morning however I can’t seem to get my phone/app to talk with the controller.

I’ve deleted and reinstalled the app. Changed lead. Updated phone (and rebooted). Tried a different phone. Given the lead a wiggle. Used top and bottom connection ports (does the bottom one even work to connect phone to controller?)

If I try and do the connect to aircraft within the fly app it immediately says linking failed which makes me think the issue is with the phone and the controller not talking rather than controller to drone.

Missed an amazing sunrise this morning!

When you tried the bottom, USB-A, port, had you removed the micro-usb plug from RC’s side port?
If that is left in place, the USB-A port won’t work.
This was always the case for earlier models, so I’m assuming the case for the MA2.

Just one lead connected between phone and controller at any time

Sure - but had you fully removed the micro-USB plug from the side of the RC?
If that’s still in the RC (and even though not connected to the phone), the lower USB-A socket just won’t function.

1 Like


Will the controller connect with no phone attached ?

1 Like

Easiest way to check that?

Not really familiar with the Air2 RC (that doesn’t have ANY built in display!), does the RC create any sounds relating to connecting?

Otherwise, power up the RC and MA2 and see if you get the motors to start and stop.

1 Like

Yes, took a bit of trying (customised controller setup). But it will start without the app

So - it’s down to just the RC and phone.

Do you have a second phone/tablet to try? Or know someone that would allow you to briefly install GoFly on theirs to check the connection?

Yep tried the wife’s iPhone. Just refreshed the controller and drone firmware as well.

I think DJI are about to ask me to return the controller to have it checked out.

1 Like

That does seem to be where the issue lies. Had it for long?

3months ish. Annoying as I’m on holiday! Thanks for your help :slight_smile:

1 Like

Hi Robbie I have an MA2 which Im still getting used to so dont know everything about it but Ive just tried mine using the USB-C at the bottom of the controller to connect my phone and it doesnt work at all. I think this port is just for charging the controller. So if you have tried another phone and tried another lead then it probably is a problem with the controller itself. Just out of curiosity, what iphone does your Wife have? Is it definitely compatible with DJI Fly? Also do you know anyone with an android phone you could try to rule out an issue with the ios version of the App?

Also are your phones in a case thats stopping the USB connection from pushing in far enough to connect? Looking at mine (Im on Samsung S10) if the connector is any more than around 1mm out of the socket it dissconnects. Not sure if that would be the same with iphone? Also my phone makes a usb style ‘bing bong’ sound when I connect the controller to my phone.

Both on iPhone 11 so no issues there. Cable definitely connects

Ok do you have your controller set to charge your phone while its plugged in? And if so does it start charging your phone?

You have to turn that on each time you reconnect with the MA2 so can’t tell.

Ah ok its different on the android version. Once its set it remembers and starts charging as soon as you connect it. Sounds like it may be an issue with the remote then although I will reiterate that if you do have a case on your phone, I would definitely try it with the case removed. It can make a big difference. As I said before, mine only needs to be a fraction out (and mines not in a case) and its in the realm of intermittent/no connection. If you think of anything you want me to test with mine just let me know. Hope you get it sorted.