Air 2s Story of what happened and to give you heads up

Some of you guys might of seen on you tube that some folk have had issues with the altitude of this Air 2s.
Well I had been flying mine without this issue and got to say it is a fantastic drone. BUT yesterday while out with it mine did this too.
Now I’ve no idea as to why but the only thing different was that I was trying active track trace.
My own lack of attention to what the readings were on screen didn’t help but in my defence I was in a woodland area and was more watching the drone than the screen as it was following my daughter in-law.
I noticed that it didn’t bypass but it braked instead, checked it was set to bypass and it was. So I took control and flew it out into a clear open field with a path going by the side of it with a couple of small bushes and the odd small twiggy tree.
So I tried active track parallel. First it told me subject was to far away so fetched it closer, perfect, off we go… Then as she went behind a bush it lost her then found her again straight away, it then flew slightly behind her and nearly into a bush, it did avoid it and went round got her in view and locked on again then just set off flying towards her and boom straight into a twiggy tree. When I got home I checked on Air Data and after 13 mins of perfect no issue flying manual and active track I noticed the altitude had started to go down even though the Air had not. Then at the point of twig trimming it was -0.3 but at landing it thought it was at -47. I will admit I was watching the drone for unusual behaviour rather than checking the screen so had not noticed this displaying. I did land a took to the air again for a few mins to try FPV and Air data showed that altitude was showing correct again…

I have spoke to DJI on the phone and they told me to connect to my computer and refresh the firmware through the computer and then calibrate through the computer too. Done the refresh but after about 10 attempts this will not calibrate through computer screen. I use a laptop so wonder if that could be why it wont. Has anyone ever tried the DJI on screen calibration before?
I’m going to have to contact them again as that’s what their program says to do under the failed calibration.

Sorry for the long waffle, but thought it might help/warn anyone else who has this issue with the Air 2s

Oh and the Flight Data Center on the phone recorded altitude as 13m which is way out as I went approximately 80m high at times… Three previous flights over 2 days before were showing correct.
Could anyone tell me where i can buy some new propellers please?

3 Likes

Re your point about calibrating on a laptop, I calibrated the sensors of my M2P only yesterday on a laptop with no issues.

Hi, thanks, I am going to give it another try today but if no luck then I guess it could be an issue with the drone so will get back to DJI… Thanks for the reply…

Update.
Spoke to DJI, was told to return Air 2s for a replacement.
Had new one and it has flown faultlessly for first 3 days.
Yesterday I noticed that it was showing -0.3 again while it was hovering just above my head and I’m 6’+. Landed it in front of me and it went down to -16. Then as I took off it flashed up -0.3 then went back to showing correct height…

Strange how it randomly does this. Hope they sort the issue soon… Until then just got to be very careful and trust your own sight rather that the readings…

Blimey! Scary thing. I’m sure they’ll fix this in no time and you’ll enjoy this amazing new bird.

did you see Phillip Skraba video his battery kept going up then all of a sudden right back down and lost it in the sea on the return flightt he was near a place Called HEL … i jokingly said well it certainly went to hell but never came back bit fitting for where he was ha! but yea the drone is a bit iffy attm witchh is a shame looks so good too!

It is a great drone but like anything new they’re always in need of a few tweaks here and there.
I have a Mini 2 which I think is one of the best little drones I’ve had.
I also had the Air 2 before this Air 2s and got to say that this 2s feels better to fly for some reason but why I do not know. So once they sort out the altitude issue it will be fantastic.

1 Like

yea i have the mini 2 :slight_smile: wish i could afford the air 2 or air 2s, oh yh like the mini 2 had a few small kinks that needed ironinng out, like the Battteries they have a problem with auto discharge been in tthe hub or drone, and how heavy is the Air 2s ?

I think it’s 595 up a little from the air 2. Compared to the mini it’s quite a lump. Got to say tho, out of both I much prefer the mini for majority of my flights. Its so much better in woodlands etc. But the Air 2s I bought for open land more than anything, and for out on the hills where it can be a little more windy and need to fly further as you can see it much more easily.
I’m disabled and can’t walk very far, so when the wife goes for a walk somewhere with a nice view I will put the air up and I too can check out the scenery. So it’s handy to have the choice of size for that reason alone…

2 Likes

Confirmed:

2 Likes

Morning All,

I had a strange one last night with my Air 2s too. I was testing some settings at 390ft and everything was okay. Then as I switched to S to return, I got a Front Sensor error then a calibration failed message. I’ve landed with no issues but I can’t complete calibration. It goes through all the tasks but then at the very end it fails at 92%. The interesting thing is the fact that the error is cleared from the drone but I haven’t tested it yet. It does seem like it has some Firmware/Manufacturing issues…

When i spoke to DJI about the altitude issue they asked me to calibrate the drone while plugged into the laptop. I tried several times and it always came back as an error and to contact DJI, That’s when they said return it for a replacement.

They will get round to sorting this issue and any others that arise.

Maybe worth plugging yours in and try checking things online using DJI Assistant 2.

I took it for a fly and no issues at all… Error not present, it stops or bypass obstacles as normal. Calibration still fails 92% on DJI Assist 2 Consumer but the drone itself has no issues. Very strange…

Yeah it is strange, they’ll iron out issues with updates soon…