Banyany Typhoon X16 - Won’t start

Hi guys first time I’ve been able to get outside now the rain has stopped to test fly the X16.
All battery’s are charged both remote and drone.
Lights come on and flash remote connects to drone all good , lights settle to constant light.
I pull both sticks down then out or in. Tried both ways hold in same position for 20 seconds but props dont start.
Lights are still on.
All help and advise appreciated.
I’ve watched several u tube videos on the X16 and as far as I know I am doing same as they demomstrate.

The binding procedure is a little counter intuitive for this model. Rather than transmitter then drone power on sequence the drone is turned on first and then the transmitter.


I’ve got it to bind now but when I started props I realised I had put the two front props in the wrong places so stopped it .
Swapped them out .
Bound them together again .
Props start but not able to increase RPM.
I have noticed the GPS is not locking.
Lights continue to flash.
I turned GPS OFF but still unable to increase Rpm. STUMPED.
Am I doing something wrong!

If it’s never has a GPS lock, the first one can take some time.

Bound drone and transmitter together.
I can then start props up / stop them / restart again without issue.
What I cannot do is
increase RPM / take off.
No responce to lever being pushed up or down.

Update I’ve taken it to Anthony at Lincolnshire Drone Repair.
Hope he can sort it out.
There was damage when I put front props on the wrong MOTORS.
When I first tried to take off it titled forwards and the props hit the ground and stopped spinning.
After refuting the correct way .
Drone would start and stop but no throttle responce .
Anthony thinks it could have burnt something out .
He is hoping to run diagnostics on it .
Fingers crossed.

Still at the drone Doctors.