Beta flight 4.3 ok till I power up and lose VTX signal

Re-flashed my mini whoop to BF 4.3 and everything seem ok till I power up and I my VTX signal drops out :man_shrugging:t3:

Have noticed on my whoop that the VTX changes from 25 to 200mw when armed. Is this the same? Must be settings for that, wonder if you changing channel when arming? What you mean “drops out”? does it change channels? I want to change mine to 350, or manual select, so going to look at that soon

Also did you update from 4.2 or lower?

That’s the “low power disarm” feature on the VTX page. I always have it set to “UNTIL FIRST ARM”

Iv tried to change channel once armed via my goggles as I’m DJI but still the same.

I’m wondering if it could be the rates as when first flashed it was on (Think its call )Active but was far to powerful, but worked fine. Changed it to BF original/ box standard not sure what that’s called either and that’s when I noticed the issue.

Thing is iv changed my rates on other quads with no problem so surely it wouldn’t be that ??.

Are you using ExpressLRS? What model is your tiny whoop?

No and beta85hd

tks… Then its not related to what I was going to suggest you try.

(for general awareness purposes) There are some boards/firmware (the betafpv and mostly crazybee) versions which are presenting some weird problems, albeit mostly radio, when having the band selector in use on the VT Administrator within the ExpressLRS Lua on the transmitter. It is suggested to keep that on “Off” for the time being and either select band, when you need, on the OSD or directly on Betaflight.

Well done more fault finding and can confirm its not down to the rates i changed or my new patch antennas. Thought it might be the wire i found with a knick in but no, think i might roll it back to an earlier version of BF. The thing thats stumped me is it was working fine Sunday🤔

1 Like

I assume you did, but good to make sure… Have you checked that the antenna is properly connected on the drone?

If so, then as you said, try too roll back to your previous version and test it out. Might be worth checking the github page and see if anyone else is having the same issue…

I have a meteor75 and have flashed to the new 4.3 as well with no issues.

Yah even tried a different antenna with no luck thought it might be my patch antennas but no, re-flashed back to 4.2 and no. I even re-flashed the ESC rolling them back 1, and no.

Really frustrating as It was working fine over the weekend, might roll it back to even older version of Bheli s see if that helps.
Other than that I’m stuck as where to go from there :man_shrugging:t3:

Oky Doky think I MIGHT be getting somewhere, just re-flashed ESC with Bluejay and its actually worse which indicates Im on the right track.

Followed Oscar L tutorial but hmmm not working for me :man_facepalming:t3:

Might try and roll it back to an older version of BJ :thinking:

For the love of god something got to bloody work :face_with_symbols_over_mouth: :rofl:

Cant fault that logic :laughing:

What problem are you having Nick? Is the vista shutting down when you power the quad? Is the vista powered up but no signal? Do you have signal but the signal is breaking up?

1 Like

When you updated to 4.3 did you take a backup/cli dump? Im pretty sure you can download a cli dump from BetaFPV website. Definitely worth a try :+1:t2:

Yep it was fine when I powered up connected to both goggles and controller but as soon as I throttle up I loose visual, but I still have power to the controller.

As I said re-lashed to bluejay and things became worse, now when I power up my signal in my goggles flashes red from the outset.

Looking back at some of the posts I noticed this ( Have noticed on my whoop that the VTX changes from 25 to 200mw when armed. Is this the same? ) and was wondering does this apply to DJI also?, as I noticed last night my had dropped to 25mw from 700mw ???

As for backing up I do have a copy due to me re-flashing it some time back …

There is a power save mode that goes from 25 to 700 (on my patched vista) on arm, and visa versa. This stops over heat on the bench. I may remove that as it stops the recording too. But you get video when armed, just when throttling up is the issue? Sounds like power issue of somehow?

Can you give us a short clip?

image

I think I saw this on a JB video, cant remember if you configure in your goggles or BF :thinking:

For digital it’s a goggle thing. Analogue in BF…if bench testing don’t keep it on too long. Maybe drop your max milliwatt whilst trying in the house?

1 Like