BN880 - GPS Configuration Issues

Like the other smaller GPS units I have, I wanted to change the baudrate and update time to 115200 and 10Hz. I have a BN880 with magometer, and after a while connected it gets sats OK (on 9,600, though the default is meant to be 36,400 it’s not).

Using u-center I just can’t get it to stick any settings I’ve changed. Polling them doesn’t give me a result either. Also can’t see the version it’s on like some guides online say you should have! Frustrating!

I set the following:


Then save it:

And nothing sticks…

Also tried the rates, but sticks at 1Hz… Despite putting in 100ms instead of 1000!


Any suggestions, must be some UBlox experts out there

Followed the guide on UMT here lower down, and nope. Nada :frowning:

I’ve tried ublox, but I didn’t really need it. Why do you need it?

are you clicking the SEND button at the bottom of the screen to action your selection of ‘save current configuration’ ?
I’ve used this a few times with no worries

BUT also, are you sure you have a actual connection with your GPS module i.e. you have graphic screens open showing sats found but more definitevly the clockface is working.

These images are empty 'cos I don’t have a module connected, but hopefully you can see what I mean :smile:

Yes send and then save. Absolutely. Had locked position and time etc. Think solved it as Mon messages weren’t on. Had to dash out but seemed to be at 10hz and 115200. Will check again later. F4s ok with 115200 and 10hz?

Going with real UART and not soft serial for this one