Crystalsky Black screen

My CSU has been working OK until today. I reset some perameters in the App and switched it off and left the battery in. This afternoon, went into field next door and set everything up ready to test my new settings and Cree lights. Switched CSU on and NOTHING. Screen was just black, no noise or any response. I thought I’d got the dreaded burnt backlight so I tried a fully charged battery and still no response. Had a look on t’internt and other people were having same problem. I took the battery out and left it for 30 minutes and the tried it again and BINGO, it switched on ok and has been running alright since (tempting fate).
I’ve posted this just for the information of other CSU users, just in case they have the same problem.


Sounds like Android just hung?

I’d have had a full on panic by that point though :blush:

No it wasn’t the app, there was nothing at all, didn’t start up. Yeah I panicked as well, thought I’d have to send another one back!
Just tried it again and it’s still ok?
Oh b****r shouldn’t have said that!

The backlight failed on mine 2 months back, had to send it for replacement. It feels far too hot when used on a bright sunny day. The biggest issue that I have with DJI, is that everything that I have owned from them has had to go back for repair at least once. This is concerning due to only a one year warrantee. If it is not working correctly, then I’d send it back ASAP. It should work 100% of the time correctly (bar some excusable slight programming bugs).