Dji firmware update problems mavic 2 zoom


#1

been trying all day to update firmware but it seems dji have a problem with their servers, now 1am and still not working check from pos 6 onwards


#2

When I did updates (pre .700 on Mavic Pro) I always had mixed results from my phone, had you tried using Assistant on PC/Mac ?


#3

used the pc and phone nothing was working,but there was an issue from DJI but just successfully updated firmware and batteries 24 hours after reported to DJI,so looks good for me to go flying in richmond park today.:grin:


#4

Well if to do fly across the river over to twickenham studios and i will wave to ya


#5

Just so that you are aware… if you can’t update your Mavic 2 firmware via your phone of tablet, you need to use…

‘DJI Assistant 2 for Mavic’ on a PC or Mac.

The normal Assistant 2 does not work correctly with the ‘DJI Assistant 2’.


#6

They’ve done a crap job on this - seriously effing confuzzling for someone with several DJI drones.

An update to Assistant, sure … but several versions to co-exist on your laptop to service all your drones? Do they even co-exist? Does the M2 version also service MP, Air, etc??

Nothing specific or logical about this.