DJI Fly app - Flying Hours Counter not updating


I’ve had my MP3 for a couple of weeks now so I’m still very much learning. I’ve noticed that the flying time counter in the DJI Fly app hasn’t moved from zero even though I must have at least 2 or 3 hours flying time in.

Is there something I should have done or a box I should have ticked when registering the drone?

Thanks In Advance

1 Like

Go into the fly app, when you click on device management what does it say ?
Are you logged in, if so I’d try logging out and back in.
Or are you referring too the bit over on the left as in picture

If there’s nothing there, click on ( more ) and check your flights are logged / saved, sometimes for me this is, I have to download them, even tho that option for me is turned on

Educated guess, others may know better.

What device are you using?

Check you have internet connection and check you are synchronizing your flight data

Thanks for the replies.

The sync flight data is enabled and yes, I’m referring to the bit on the left.

How do I manually download my flights?

I’ve got the DJI RC and the app is on my iPhone 12.


1 Like

When you click on more on the left what does it show, maybe upload ?

Edit : if the flights are all there but not showing as you say, this has worked for me btw, click on each flight and click out individually this some times puts them there or back, I’ve had to do this, give it a try.

No upload button. It just says “All Aircraft” and it’s ticked.

1 Like

Try clicking on each one separately and click back out, this has worked for me

What device and drone?
and what version of the fly app?

He says I phone 12 @Sparkyws mini 3p

1 Like

There’s nothing in my flight data centre to click on. It just says zero for everything like it’s never been flown.

You need to connect the DJI RC to your Wifi and sync the flights from there

When they have uploaded after a while they will show on the iPhone

DJI’s servers aren’t very fast at times

Ah ok, sorry i can’t be of anymore help, try what as @Sparkyws says, hopefully that will sort it.


Thanks chaps, I’ll give it a go :+1:

Sometimes you have to force close the app and then start it up again to sync

when you get it sorted then try, use the free version, best on a pc but works on phones as well


This :fu: /

or even instead of

How did you get on, did you get it sorted?

Sorted it now. The controller wasn’t connected to the WiFi. I’m not sure why because when I first switched on it was connected cos the firmware updated.

Thanks for the help chaps :+1: