DJI Go 4 and iOS 13

Has anyone tried the DJI Go 4 app after installing iOS 13? Any problems?

I wouldn’t trust a beta OS for a drone flight.

1 Like

No I wouldn’t either however it’s officially released now so?

Oh is it?

Shouldn’t be a problem then :man_shrugging:

I’ve downloaded iOS 13.1 on iPhone all working fine with latest release of Go4

Last night, I also noticed that iPad iOS had been released early, just checked it out now, again all working fine with iPad iOS and Go4.


the new dji go 4 wont let me start waypoint missions , I tried it on my android phone and all was ok
anyone else experiencing the same problem?

What drone?

mavic 2 pro, the done works perfectly with waypoints on litchi

what is happening is that , I set the mission points and poi, but when I press go to start the mission , the task checks appears but no start option . my ios is 13.3

Right then, the app is glitching, make sure all flight logs are synced to the cloud and then uninstall the app and reinstall it. Let me know how it goes.

Also is ALL firmware updated?

can you talk me through the process please

DM me