DJI goggles update

Anyone got any idea when the latest DJI goggles update is due ???

@Nidge would know if anyone

Nevermind that just do this. I’m only usually 600m away but in a gully of trees. Signal is not great. But this makes it at least 80% better. Just follow the instructions. 30 secs and it’s done. To go back to OEM just reconnect to the DJIFLY app


Or for those of us without an android device

1 Like

Sorry my fault, I probably didn’t make myself clear ( to much Guinness last night )

My question is in reference to Ian of Mad’s Tech post on YouTube …

Mine are usable ( Just ) as they link to my Caddx unit but I have no OSD, hence Im using the timer on my phone as not to run my batteries down to low…

I’ve just taken the plunge with the DJI goggles… about a week before that video came out so fair to say I was a bit :open_mouth: tbh.

Story so far, they were a pain to update but once that was done they’ve been spot on. I also did the US region unlock.

I have a Beast F7 AIO with the Caddx Vista wired to UART 7 and I get full OSD, inc GPS home arrow etc. Not sure why you have no OSD :disappointed:

Cheers for that mate, me neither Iv watch a number of YouTube videos but cant seem to get the OSD up and running :angry:

Im running firmware 603 at the mo which lets me fly but thats it, Iv tried in vain to update to 606 and 604 but just want have it.

Can I ask what you are running and what benefits does unlocking the US region have ??..

I did read about the UART but thats Unicorns and Wizards to me as not been in the FPV game that long …

There will be 2 wires that will need to be soldered to the Vista and the other end to a spare UART (think of a UART as the flight controllers usb port) on the flight controller. And configured in betaflight to get your OSD working.

Skip a long the time stamps till you get to the wiring for the vista.


1 Like

cheer buddy :+1:t3:

1 Like

@BigDog - it’s not too bad - but it does take some getting your head round everything in BetaFlight. I’ve been at this approx 8mths now, knew nothing to start off with. It is frustrating trying piece all the bits together when you’re first getting into it.

In regards to the US region. The goggles are locked to 25mw max in the EU. The ‘hack’ to unlock full 700mw and 8 channels is v. straightforward… (skip to 4:10)

1 Like

Now that is easy, even I could do that :rofl:

Cheers Il give it a go :+1:t3:


Ok as to trying to resolve this iv took the quad back to default setting, seemed a good idea at the time but now I have this in Betaflight …


The following problems with your configuration were detected:

  • there is no motor output protocol selected.
    Please select a motor output protocol appropriate for your ESCs in ‘ESC/Motor Features’ on the ‘Configuration’ tab.
    Caution: Selecting a motor output protocol that is not supported by your ESCs can lead to the ESCs spinning up as soon as a battery is connected. For this reason, always make sure to remove the props before connecting a battery for the first time after changing the motor output protocol.
  • the accelerometer is enabled but it is not calibrated.
    If you plan to use the accelerometer, please follow the instructions for ‘Calibrate Accelerometer’ on the ‘Setup’ tab. If any function that requires the accelerometer (auto level modes, GPS rescue, …) is enabled, arming of the craft will be disabled until the accelerometer has been calibrated.
    If you are not planning on using the accelerometer it is recommended that you disable it in ‘System configuration’ on the ‘Configuration’ tab.

Please fix these problems before attempting to fly your craft.


Can anyone please advise on (no motor output protoco)

Did you do a CLI dump of your configuration before you reset betaflight?

But to answer your question you’ll need to set (I’ll have a guess at DSHOT 600) on the configuration tab.

Ok, iv tested my quad after resetting and its made no difference to the OSD.

But I tried my other quad and that seems fine, I even went into Betaflight to change some of the icons I see and all seems fine.

On closer investigation I did notice I could flick between standard and custom in my goggles.

Therefore im thinking it might be something not ticket or ticked in betaflight preventing my goggles displaying the custom display…

So is the issue now that you don’t have an OSD on 1 of your quads but you do have an OSD on your other quad?

Cheers mate found it do I have to set it all up in there as its asking for thing like ESC_sensor and other stuff ???

It is the bloody thing !!

You’ll need to know what UART number your vista’s TX and RX wires are soldered to. Then in your ports tab on betaflight you’ll need to set that UART for MSP to on to get your OSD to display :+1:t2:

Take a photo of your ports tab and post it here :+1:t2:

Ok this issue is all sorted now, more luck than judgment :rofl:

thanks for the help :+1:t3: