DJI Groundstation not working on iPad Pro 9.7

I have added a DJI Datalink 2.4GHz Bluetooth unit to my retro Droidworx build.

Air and ground units communicate and all firmware is at latest level

I have an iPad Pro 9.7 inch (First generation iPad Pro) which has Bluetooth 4.2. The DJI Groundstation app requires Bluetooth 4 so should be compatible - it runs on iPad3,iPad4,iPad mini, iPad mini with Retina display,iPad Air(iOS 6.1 or above)according to DJI.

From the timeline the iPad Pro came out after the Groundststion manual was written:

Any idea why the app fires up but quickly displays an opening screen then closes?

Because I’m getting a tiny bit annoyed …

Is this just Apple being dicks with Bluetooth?

Once upon a time they were convinced the only thing anyone would ever want to do with Bluetooth was connect headphones. They absolutely crippled the BT comms.

That was many years ago, I’ve never tried to connect anything since.

Apple, Microsoft and DJI are all guilty of producing kit that doesn’t play nice with the other stuff that conforms to standards, each of the above manufacturers seems to think that they should be the ones that other, lesser concerns should change their inferior offerings to comply with them.

But the app works on similar Apple products. I just wondered if any one with a long-term involvement with UAVs could cast their mind back to a time when a DJI 2.4 GHz Datalink worked with the groundstaion app on an iPad Pro …

1 Like

I’ve been using the Datalink on my F550 since the beginning of 2014. At the time I was using an iPad Air. I’m now currently using an iPad 6th Generation. Unfortunately DJI dropped all support for the Datalink in 2015 after they refused to update the Google API on the PC version, and added ridiculously large NFZ’s to the iOS version.

It maybe a GPU issue as the original Air and the 6th generation iPads have the same displays. Have you tried using the iOS Naza Configurator as this uses the same BT standard.

I’ve just tried to run it on my wife’s Air2 and it crashes. This leads me to think that the GPU in your Pro doesn’t like the APP as I think it’s similar to the one in the Air2.

I’ve just checked the APP revisions and the iPad Pro was released after the APPs last update. The APP was last updated in March 2015 and the iPad Pro was released in November 2015.

The only options remaining are to either use an Apple device without the Retina display, or use a PC with the UGCS software that works with the Datalink.

Just tried PC UGCS and it won’t display maps - I am using an 8 core AMD FX processor and Radeon 8GB GPU. Maybe a little bit frightening for the poor wee DJI program?

I’ll give it a whirl tomorrow - need a break for tonight - on my low res, low power ThinkPad and see if that works better. Otherwise I’ll be looking for a recommended iPad as in the opening post - though some have retina displays!

I’ve solved the problem - on iPad.

The Ipad Pro just shows the startup for GS and bombs out. So I bought a secondhand iPad 4th generation off eBay.

The seller does a big trade in pre-used iPads, this was ordered Sunday night and arrived, as expected today, Tuesday. The box contained a “good” grade IPad $th gen, 64Gb and in rather better cosmetic condition than the “good” grade was described in the listing. The tablet was well protected inside the box and good value at £99 - with a discount code from eBay last weekend bringing the price down to 79.99 - cheaper than private sales of some 32Gb models that same weekend.

The Pro runs IOS 13, the iPad 4 run IOS 10. It will load a downlevel version of DJI GO from the Apple Store but not GO4. That began to look good. I loaded Ground Station without problem, fired up the bird, the datalink RX and TX and the Futaba TX. Opened GS on the iPad - it went all the way through startup, found the A" flight controller and demanded a password. Once that was done the simulator could be fired up and all seems to work!

Solution - when using unsupported ancient software find an ancient bit of hardware to run it on :slight_smile:

3 Likes

Now it’s my turn.

Yesterday when you posed your question I fired up the GS APP on this iPad and it was working fine.

Today I’ve just fired it up again as I’ve installed a Datalink on my Steadidrone Q4AD and it just won’t work. Exactly the same issue you were having with your IPad Pro. I haven’t updated anything so I’m stumped now as to what the cause maybe.

Just checked the Naza-M Assistant APP and exactly the same issue, even though that was working fine yesterday.

Sorry to hear that.

So no hardware changes in the iPad. New Datalink. I assume link lights in both ground and air units show green. Is the bluetooth unit showing green? Can the iPad see it?

How does the NAZA communicate with the uPad? Bluetooth or wire?

Has the iPad had an OS update since you last used it? Or have you added any apps?

And are the units a couple of metres apart - apparently if they are too close its not good

Those are my random thoughts before hitting the sack. If I think of anything else I’ll let you know

I’ve no other thoughts to add to those you’ve already had, Rob.

I’ve deduced it’s something to do with the way the APP is trying to access the BT hardware in the iPad. If I turn off BT on the iPad both APPs fire up fine and I can navigate through the menus, even create flight plans and save them. But as soon as I enable the BT on the iPad the APP crashes.

I’m thinking that iOS has changed the way it lets APPs access hardware. With most BT connections you have to initiate a connection by the device settings, but with the Groundstation APP it’s the APP itself that creates the connection. I updated the iOS version this morning in the hope it was a bug in the previous release but it’s still behaving the same.

If we were dealing with any other setup it might be possible to find the fault and rectify it. As it is with both Apple and DJI both systems are closed, the worst marriage in RC history.

I do have one option left. I have an Android/W10 dual boot tablet which I can run the UGCS software (Universal Ground Control System) under its free use license. This works with the Datalink hardware, along with Ardupilot, Anafi, and DJI P4’s and Spark’s and Mavic’s when the controllers are connected to the USB port. I haven’t tried the Datalink with the Naza Assistant software on the PC but it might work as it sees the Datalink as a DJI Virtual Com Port exactly the same way as if you plug the Naza directly into a USB port, I think they use the same driver. I’d like to retain this feature as it’s much easier to make changes when the drone is in the air, as opposed to landing and plugging into a PC every time you want to adjust a gain setting.

But at the end of the day it is a DJI product and since the last GS APP update in 2015 we’ve been running on borrowed time.