DJI Mini 2 Camera Issue?

Has anyone else had an issue with their Mini 2 where the camera will not come to life, drone connects to the controller and app, gets sat lock and sets home point but screen is black (even when camera settings are adjusted for exposure)?

Happened to me this evening, it happened once before when I was trying to fly at night and I put it down to me messing something up. This time I checked and double checked everything and it only started working after two reboots (of the drone and controller) and restarting the app. Oh and I also reseated the micro SD card.

I think I have the latest Fly version as I downloaded it from DJI directly and the firmware doesn’t indicate any update required.

“Camera issue” ?

The fact that you have no image on your phone might not be anything to do with the camera.

Should it happen again - try recording video or taking pics, and check if these look OK on your computer.

If they do - it means there’s nothing wrong with the camera … and the problem probably lies with the phone/app.

Good idea, hadn’t tried that as the app itself appeared to be fine.

1 Like

Also worth checking the cable as I had a cheap link cable and that gave me some problems but you might be using the original DJI one but I was using a tablet hence longer cable

Which phone/tablet are you using?

It’s a Samsung Note 10 Lite.

How much memory do you have on the phone check your not near the limit

1 Like

Except you could see anything from the camera

I’ve had this blank screen problem happen to me a few times now and it required everything to be shut down and restarted again.

1 Like

It’s happened to me a couple of times. Had to restart drone and controller, then plug the tablet/phone in. Works every time now.

1 Like

I’ve seen one of the drone YouTube guys who does that every time but never known why , maybe the way to go .

1 Like

I’m getting the same thing but with an MA2, screen is either black or white, looks like under or over exposure. I’d had thought it might be something to do with switching between the MA2 and the Mini 2.

Checked just now (same stuff running as last night) and it showed 1.8GB. After optimising it went to 2.8 GB.

Indeed, but if it were app related I would have expected everything to be affected or it to not load full stop. I may have had the Go app running in the background, likewise Litchi which could be a possibility if they interfere with each other not 100% sure if they were, but I had used them in the last few days.

Correction: They were both running, I just looked and all three apps were still loaded up, wonder if that is the cause.

In my case it is two different apps; Fly and Go but it could be a similar issue.


They don’t play nice together, I often swap mid air but make sure one is closed fully before opening the other (Litchi do recommend not using while DJIFLY/GO is open)

:point_up: :point_up: :point_up:


The one app must be fully closed (not in background) before another app can access the controller.

1 Like

I had this too - my Mini2 didn’t like the memory card that had been used in my M2P.
Formatted card and then worked fine.
I keep dedicated cards for each drone now.

I found it the same with Dronelink, when switching between them I had to kill the one I was closing. Can’t leave one running in the background.

It doesn’t matter which apps are involved - DJI’s apps, Litchi, Drone Harmony, … or any other one.

1 Like

I’ve had the same issue and solved in a similar way. Havent had it for a while though- touch wood.

Something to add to the mental checklist I think, close all unnecessary apps and clean memory prior to flying. Good phone hygiene :upside_down_face: