Help needed calibrating with DJI Assistant on Mac OS

I’m getting really fed up with this.
Every time I launch DJI Go, I get nagged to calibrate the sensors using the fabled DJI Assistant. It DOES NOT BLOODY WORK on a Mac. At all.

“Follow the square”, it says - but all I have is a blank white screen. No dots, no squares, nuffink.I don’t have PCs, and the new iMacs don’t let you dial the screen res down (which apparently may or may not work). Has anyone figured out a way round this? Or has anyone got the older DJI Assistant for Mac (pre 1.1.6) which might work?

Oh, and please can we not start any flame wars on operating systems? This is a nice friendly place, and let’s all play nice. Personally, I much prefer the Mac OS. Well, I did up until just now!

I’m no techie but I don’t have a problem with DJI Assistant on my Mac Pro - running the latest version too. Why does DJI Go want you to recalibrate the sensors via Assostant? Never met that before - always done it within DJI Go.

I can only suggest uninstalling and reinstalling both DJI Go and DJI Assistant - if you haven’t done that already that is!

Sorry I can’t be any more helpful - good luck getting it sorted.

Thanks for the reply, BCF.

Sadly, I’ve done all the downloading and installing already. To no avail.
I’m not sure why it’s suddenly appeared on Go, but there’s a flashing red bar saying that calibration via Assistant is needed. It all looks a bit ominous, and I’m not keen to fly with warnings like that.

Had a mate whose P4 went rogue and head-butted a tree. Did all sorts of damage, and I’ve always been wary after that.

errrr, that is, the Phantom headbutted the tree. Not my mate!

1 Like

Good luck, can’t help much…No Mac:wink:
Seriously though, do you have other fruit based devices you could try?


Nope. I’m a bit stuck, really. I’m Mac (and iOS) only at home and at work, and the IT droids at work won’t let me borrow a PC laptop to download “unsupported software”. I’ll just have to live with it, I guess. Thanks, though.

I had no luck with DJI assistant on my Mac, every calibration failed, It turned out to be the USB cable I was using, no idea what it was but a different cable just worked.

Cheers, Steven. But surely if I get no dots or squares on screen - just a white rectangle - that’s the app at fault, not the USB cable? I’ve tried this on three separate Macs now. This sucks.

I’m missing something here… which sensor(s) is the app telling you to calibrate?

And perhaps a bit extreme but if you’re running out of options, any GADC members nearby that could invite you round for a brew and a loan of their Windows computer? Or what about setting up a Windows VM? Again, a bit extreme… but, well, you know… you’re fast running out of options :frowning:

LOL! I actually laughed out loud when I read that :rofl: