Jittery & Jumpy Recordings - Mini 2 any advice?

Hi all,

I was out recording early Sunday and right from the off the picture when recording on the Huawei Mediapad M5 Lite was jittery and stuttering. Final recorded videos from the drone’s SD card were fine but can anyone suggest why this was so and what I should do to rectify it.

Filming in 2.7k at 48fps. DJI Mini 2. No other apps running on the tablet apart from the DJI Fly.

Any help appreciated.


Are you recording the feed or just taking about the transmission you’re receiving when flying?

I would assume the transmission I’m receiving as the end video was fine. I should have been a little clearer. There were no drops in signal with full bars the whole time I was recording. The only thing different to this flight to all my others is that this was in an airport hazardous/fly with caution zone.

1 Like

Just a long shot, was the jittering all the time or just why yawing. Have you tried any combination of 30fps/60fps/120fps. I had trouble with jittering on 25fps but it was a lot better with 30/60fps, probably something to do with the screen refresh rate.

It was all the time while recording and I did try reducing it to 30fps but it didn’t make any difference. Strange thing is I’ve always filmed at either 48fps or 60fps and always at 2.7k and never had a problem until now.

I know exactly what you are asking. Are you recording to memory card on the media pad, or to its own internal memory? If your memory card isn’t fast enough it’ll be jittery, stop start. You’ll need a fast memory card.
The HUAWEI seem to be jittery handling 4K. I went into settings and reduced the size to 2.7K. There’s very little discernible difference unless you are going to be zooming into,photos.

Cheers Brian. It was writing/recording to a Sandisk Extreme Pro 128gb card in the drone and it was 2.7k at 48fps. Nothing had changed from the last time I flew yet this happened. Very weird

That is weird.

What speed card is on the media pad?

And why are you recording it ?

My settings send video straight to ipad/media pad, I can then use editing apps without dragging around a laptop and fiddling about taking the SD card out of drone every time. The ipad/media pad doesn’t have a USB slot for a card reader.
My media pad and phone are both intetconnectrd

My tablet has no SD card in it. There’s no data. It’s purely for the drone, nothing else

I’ve sinse read on Faceache that a number of Android users are having the same issue with 1.4.2 of the app. I’ll update to 1.4.3 as apparently that’s out now, see if that fixes it.

1.4.3 is only ios, for now, 1.4.2 is Andriod’s latest

I had the same issue and fixed it by deleting the Cache files, then uninstalling the app. Restart the device and install a fresh new download

Tested it last night, but only in the kitchen! and it seems fine :crossed_fingers:


Thanks, I’ll give that a go tonight

1 Like

Right, cleared Cache files, uninstalled the app, reinstalled and restarted the tablet. All to no avail :frowning: Still very jittery.

Swap over to my Galaxy S10 and its fine so it’s definitely the tablet or cable as one is USB C to Micro USB and the other is USB C to USB C.

Could the speed of the SD card in the tablet make a difference? Cache files are written to the tablet memory aren’t they?

About to throw the missus out the window in frustration!

Try it without the Sd card, remove it and see as you don’t need one it will then write to the internal memory

Also, I would try the older version of the app, I haven’t test mine properly yet but will try tomorrow if the weather improves

1 Like

I’ve tried that but still no joy.

Incidentally, DJI don’t list the Huawei M5 Lite as one of the compatible tablets in the list on the app download page. I assume that’s because the list isn’t exhaustive, yes?

The Lists are the ones they have tested and support!

Have a look at background apps, what else is running, have you installed any other apps

You could try a factory reset,

Maybe ask the rest of the community @group-android

1 Like

I’ve never used a device that they list as compatible - never had issues. And they’ve all be cheap, too.

There are literally thousands of different Android devices, and they can test only so many, and those they list.
This most definitely doesn’t mean that others are incompatible.