Latest update

Updated the Mavic yesterday am because I am going abroad this afternoon so I thought it would be wise to do it to save any hassle whilst away…
Well all seemed ok, tried the quick shots worked great, a coupke of small issues but soon sorted them, but this morning went to try a few things… the app would not link to the Mavic 5 times when it did I tried a tentative take off it hovered ok and then started moving around and then yawed to LH very fast and then shot up to about 50ft, RTH failed.
Got it back, landed and did a full reboot of everything once again failed to pair with the Mavic so tried Litchi this said unable to connect multiple flight modes require setting in DJI, WTF is that ???
And Sports mode dosnt work ???
Should I turn it back or just see if things sort them selves out ???

If taking abroad, I would be tempted to get it back to a working state.

Don’t need the hassle or, god forbid, heartache, whilst away from home.

1 Like

Android or iOS @Ktm250 mate?

Excuse my finger-drawn annotations but you’ll get the idea :slight_smile: My GO4 won’t let me switch the remote in mid-flight to sport mode unless this is on:

IMG_0561

Thanks for that it looks like it’s up and running ok now fingers crossed, first flight in Turkish air space tomorrow…

1 Like

Good luck mate, be sure to post some #media when you’re back :smiley:

1 Like