Maps on CrystalSky

Well I got my 7.85 CrystalSky on Monday but had to wait till today for the charger I got from Njoro. So connected it all up indoors to see how it works, everything seemed fine but there was no map in the mapbox.

It did takeoff ok and just hovered it and landed again. I then wanted to put a few apps on it for which I had downloaded the apk files. UAV Forecast installed ok, but took ages to find my location, but only as current location, no address as it does on my phone or tab, and no maps.

Couldn’t install Met Office app, and installed Drone Assist which after signing in asked for Google Play Services and could not find location.

I’ve checked the obvious things, wifi is on and location is set to high accuracy. In one way it doesn’t really matter I can’t get maps as I can use my phone, but it would be a lot more convenient.

Can anyone help.

Phil,
Just picked up a CrystalSky myself, I had exact same issue, but when I was outside it picked maps up ok, I turned WiFi on the CS and used my mobile as a hotspot.
I found this video to allow you to download offline maps, not sure if it will help you. Just out of interest what firmware is the CS on?
Cheers

1 Like

@mickydd

Ok, that’s interesting that it picked up the maps outside, whose maps are they? I’m connected to my wifi indoors, but still no maps. The wifi is working ok as I’m able to use the internet. I also saw this video about offline maps so I tried it and it just sat there with the little circle going round and round, so I gave up on that.

It seems a bit much paying £670 and you can’t even get some basic apps to work. the system version is 2.6.6.0, I assume that is the firmware.

The map display is mapbox
Am sure it will be a simple fix, really like the CS display

So any of you having an issue with the keyboard when naming the downloaded map? I’ve found that as you type the first letter it will not accept the following letters but comes up with predictive text which has no bearing to anything you might be typing.
I looked in settings but can’t find a way to turn it off, anyone with this issue or remedy?

@PingSpike you’ve had yours for a while now, any pointers welcome.

No sorry mate, the reason I’ve not commented on this thread is because I have nothing to offer :confused:

In the past I used to run my own custom-rolled GO v4.1.22 (December 2017) on the CrystalSky which alongside various tweaks (FCC, NFZ, etc) was using the old fashioned Google Maps - the one where you browse to an area, pan around a bit and it just cached the map tiles locally automatically. They should never have changed that, it just worked…

But these days I only ever fly using Litchi as it works with both the Inspire and the Mavic, so it saves me switching between GO3 and GO4.

It also saves me from all this grief :grimacing:

2 Likes

Haha, thanks, I suppose I have to buy litchi again.

I’m pretty sure that I posted on here about predictive text. There is a settig that needs altering. I’ll see if i can find it.

For some reason mine is ghosted…:man_shrugging:

Hi Guys

Well I just went out in the garden, set everything up, started up Go 4 and no maps, nothing at all.

Is this mapbox an app or is it just the little box in the corner of the screen?

On the good side it was nice and sunny in the garden and I could clearly see everything on the screen without being in the shade.

If anyone else has any idea about the maps issue drop me a line.

@PingSpike

So what maps does Litchi use?

You can switch between Mapbox and Google (if you jump through some hoops first) - https://flylitchi.com/dji-monitors

@PingSpike
What is Mapbox and where do I get it, can you install it and google maps on the CS

Come on Phil, you’re not even trying now :rofl:

https://www.google.co.uk/search?q=Mapbox

And / Or: https://www.mapbox.com/

It’s built in to Litchi (and some versions of DJI GO4).

No. But you don’t need to, as it’s built in to Litchi.

@AprilCoon don’t let this whole Litchi thing detract from your original question / issue mate :blush:

@PingSpike

OK but surely I should be able to get some maps without installing Litchi, I just spent £670 on the thing and I cant get maps?

I agree mate :+1:t2:

One point to note, the GPS in the CS is absolutely useless.

The only way I could ever get maps to work on the default GO version was to put the Mavic out on the lawn in the back garden, then launch GO on the CS, so it used the position of the Mavic.

Your maps may not be loading because the CS has no GPS lock - despite you being stood outside.

You also mentioned the CS firmware version above, which is current, but is there a GO4 app update pending? :thinking: You can check this from within GO itself (I forget where that option is though, as I never updated mine). Try the About section of GO4 maybe? :thinking:

I found this on another site with regards to updating GO4 on a CS:

In the main screen of GO4 in the lower part of the screen you see the '‘Me’ button. There should be a blue mini icon on top. Click on it, and try a manual search for update. (You must be connected to a WiFi hotspot with Internet connection)

1 Like

?this is reply to the same question on Mavicpilots/crystalsky forum

Couldn’t understand why this was happening so went rooting.
Don’t know if you’ve sorted this but if not, go to Settings, - language input - Android keyboard - Text selection and switch OFF Auto correction and “Show correction suggestions” to Always hide. “Other options”, deselect “next word suggestions” This worked for me but not quite sure which of the above options it was, so just do them all !!

2 Likes

Evidently the problem with renaming maps has been resolved in an upgrade to Go 4 to version 4

I had tried that but it wouldn’t work, I updated Go4
and now it works…strange… I thought the tablet was up to date when I got it.