Mavic air 1 not hovering still

Hey guys. I’ve noticed that lately, my original mavic air, does not hover still in one place. I though the propellers where damaged/scratched so I replaced them for a new set with very little if any improvement. The device is now out of warranty, and even though I do not fly it often it does move ok and does not do anything else (apart of the slowly turning while hovering.

I have reset the controller sticks and still does not do much of a difference.

Have any of you experienced anything similar with your Mavic Air 1?
If so, any tips on how to deal with this?


It could be worthwhile calibrating the IMU and the vision system.

IMU can be done with controller and phone / tablet. You will need a flat surface to place the aircraft on. No idea why the video thumbnail is showing an exploded view, there is no disassembly required - it’s just slightly more cpmplicated than compass calibration.

VPS calibration needs a PC or a Mac to do this. Probably not required but worthwhile as part of scheduled maintenance.


Thanks you for the super fast reply.

I have already tried in the past to do the IMU calibration, I might have to give it a try once again.

With regards of the VPS calibration, again, I managed to get it done in the past (I battled with different versions, drivers and all sorts until it worked) haven’t tried again. I think it might be due.

I appreciate the help. I’ll report once I have done it both.


The IMU calibration isn’t that clear - or I was having an off day. It tool me a while to work out the positions the process wanted me to place the aircraft so I had a couple of false starts. Once I’d sorted that out it was an easy process.

I agree, @macspite, the IMU calibration it’s fairly easy.

The VPS on the other hand, is more unreliable than a 1970s fiat panda, and that’s saying something.


If you haven’t already done so a compass calibration in an interference free environment may alleviate some of the unwanted movement. In severe cases the drone will perform what is commonly called toilet bowling, whereby it will start off with small circular motions which spiral into large uncontrollable circles. This is because the GPS and compass are conflicting with one another.

With regard to the VPS and obstacle avoidance calibration, if it’s the same as the Powervision PowerEgg X, I found the best results were obtained with a dark background behind the computer’s screen so providing a greater contrast.



I have calibrated the controller and the IMU, it seems that it’s the trick. Also, as I have not used it for a while it asked me to calibrate the compass, but that’s something that I have to do often anyway.
Thank you both.


@Nidge I forgot to mention, the issue was different to the you described. When standing still, it would start to rotate or to move to one side. No sway or nothing like that.

I will however try to also calibrate the VPS also.

1 Like