Mavic Air controller calibration problem

Having a serious problem with my Mavic Air controller. I have not heard anyone talk about the same problem at GADC, but here’s hoping!

Problem started when I was away on holiday last week. The controller started making a loud beeping tone as soon as it was switched on. It didn’t matter if connected to the MA. First time it stopped once the MA was in the air but now makes the noise continuously.

I have also noticed the MA is flying strangely, as If in ATTI mode rather than GPS. When moving left of right the MA doesn’t stop when the stick is centred but continues to ‘travel’.

Checking on the internet showed that the noise from the controller was most likely due to to a stick calibration problem. I have completed the calibration several times which stops the noise that time, but the drone still flies erratically and the beeping tone returns once the controller is switched off and switched back on again.

Any help / ideas appreciated!

The only “beep” issue I can recall is : Couple of questions about litchi

This could be a possible similarity - albeit on the MP.
(Possibly nothing to do with Litchi … if the title makes it look unlikely to be related.)

Thanks Dave but definitely not connected to Litchi

Exactly … nor was the issue in that thread. The title, as I suggested, is misleading.

Sorry Dave, should have read properly. No it’s not the same , the continuous beeping is far more regular than the obstacle avoidance. Now home and doing more testing, I am really worried by the way it’s flying, especially as no warnings on the main screen. Everything reports a ok, apart from the beeping and the flying!!’

Anyone with another controller you could temporarily try? Glenn might have one from his lost (and later found) Air?

Might be worth a re-flash of the firmware on both RC and Drone so you’re starting fresh.

I’m guessing you’ve done a compass calibration already? Tried an IMU one yet?

I had a similar issue on one of my old Mavic Pro’s whereby the right wheel was decidedly iffy. At the point of booting the RC it’d do exactly the same thing, constant bleeping like that.

Got in to the habit of wiggling the wheel a lot, before powering up the controller. It never went away on that one though :confused:


Thanks Rich :joy:

Thanks for suggestions guys. I had done a compass calibration and now an IMU calibration (one of the levels was showing slightly higher before and now all the same).

The beeping has stopped but the MA was still not responding well to left and right instructions, sometimes stopping and sometimes just drifting. Did another control stick calibration and was better but a bit blustery in back garden and lots of obstacles to cause it problems.

Think I will follow advice and do a complete firmware update on unit and controller and then try again on an open space tomorrow.

Thank again for all the suggestions :+1:

Are you getting any warnings on the controller while beeping, like “Stick EMI” ?

1 Like

Absolutely no other warnings at all, which I thought I would have.

Seems to be a common google …


The bleeping is not common but known and related to the calibration of the control sticks. Supposedly normally resolved with Control Stick calibration.

I seem to ha e resolved the beeping now, just need to confirm I have resolved the lack of response/drifting of the drone.

Full firmware refresh completed so hopefully testing tomorrow, fingers crossed :crossed_fingers: