Mavic mini DJI Fly App Phone compatibility

Hi all

Can’t install the DJI Fly App on any of my 3 phones as it says they are not compatible…okay so 2 are cheap and nasty but my main Samsung A3 (just purchased) isn’t any good either.

Can you guys let me know what phones you are using that turn our to be compatible…(the cheaper the better)

Cheers

Paul

Before you head too far down the cheap n cheerful route, it’d be worth finding out why your existing devices aren’t compatible.

If they don’t have enough processing power or similar, you could very well end up in the same boat with a new (cheap) device.

DJI currently have these devices listed on their compatibility page:

Requires Android 6.0 or above.

Compatible with Samsung Galaxy S10+, Samsung Galaxy S10, Samsung Galaxy S9+, Samsung Galaxy S9 , Samsung Galaxy S8+, Samsung Galaxy S8, Samsung Galaxy S7 edge, Samsung Galaxy S7, Samsung Galaxy S6, Samsung Galaxy Note9, Samsung Galaxy Note8, HUAWEI P30 Pro, HUAWEI P30, HUAWEI P20, HUAWEI P10, HUAWEI Mate 20 Pro, HUAWEI Mate 10, HUAWEI nova 5, HUAWEI nova 4, HUAWEI nova 3e, HUAWEI nova 2, Honor 8X, Honor V10, Honor 9, Honor 20 Pro, Honor Magic 2, Mi 8, Mi MIX 2S, Mi MIX 2, Redmi Note 5, OPPO Find X, OPPO R15, vivo NEX, vivo X27, vivo X21, vivo X20A, OnePlus 7, OnePlus 6T, OnePlus 5, Pixel 3 XL, Pixel 2 XL, Pixel 2, Pixel, LG V20, LG G6.

Thanks for that PingSpike…

My Samsung has 1.5ghz processer , its a same DJI dont list the minimum phone capability instead of the phone name.

I will investigate the phones in the list

Cheers

Paul

…where on earth do you download the app? Can’t find it in the play store!!

there is a link

Try this

Thanks for that

We posted it here yesterday:

1 Like

Agreed, the list of compatible devices could run in to the hundreds eh?

I’ve installed OK on three Android phones, of varying age and Android versions back to one that’s 5 years old on Android 7.1, none of which were at all expensive when new.

At what point of installation is it saying it’s incompatible?

1 Like

Hi Ozone

It says incompatible as soon as it comes up on google play.

All my phones are running Android 7 minimum, I wonder if its the process speed, but the samsung A3 is new so should be ok.

I have it installed on a Lenovo 10" tablet ok, but that is obviously to big to use with the controller.

I just had online chat with DJI help asking what the minimum process speed should be and they couldnt tell me

I doubt that it’s a processor speed … since my old Wileyfox Storm is so old, and the Wileyfox Swift was so cheap. :stuck_out_tongue:

I don’t even think GooglePlay’s compatibility even bothers with processor speed checking (judging by some apps that have downloaded OK but run like treacle!) Usually an incompatibility is as a result of OS version or specific hardware requirement … and the requirements having been incorrectly specified by the developer.

If the latter, then it’s something that might be corrected soon by DJI.
I know I had this on something a couple of years ago … and after a few days it cleared.

Still can’t find the app, I know, I’m stupid. Just a simple link??? Anywhere??

Look up a few of posts … link to the other thread by @PingSpike which has both iOS and Android links.

1 Like

Thanks Ozone

I must admit it’s p*ssing me off.

One thing that actually amazes me in this modern world … how any app is developed that can run on so many devices and OS versions when the developer has probably only got a couple of test devices.

I don’t know much about Android, but have you tried installing the APK rather than going by what the Google Play store says?

Click this link on your phone: https://service-adhoc.dji.com/download/app/android/3b03cb95-bc4b-4b62-b4ab-9cf977d77309

Got the app, thanks @PingSpike!!
Seems to work alright on my Samsung Galaxy S7.
Now waiting for my drone. As a total beginner I find the tutorial in the app most helpful!!!

2 Likes

My thinking was working in parallel with @PingSpike

I’ve just extracted the APK and uploaded.

You can download from here :
https://www.dropbox.com/s/5pp9h53kqi7tv1p/dji_fly_1.0.1_2041195_dji.go.v5.apk?dl=0

1 Like

Thanks for that…Ozone & PingSpike

Transferred the Apk to the phones and it tries to install but after about a minute reports it cant be installed. I have checked settings to allow from unknown sources etc but it just refused to install.

Its beat me I think…looks like I will have to buy a phone off the approved list.

Very strange.

I can’t imagine it will be long before similar reports for the A3 (and goodness knows how many other teething problems globally) force DJI to update the app. Might save some money just waiting a few days? … as frustrating as that would be.

1 Like