Mavic pro, can't fly, wont fly

Well i was going to post some videos of a great holiday on St Mary’s isle of scilly, instead i’m sat here trying to figger out what went wrong.
Before i went i phoned the airport and told them where i wanted to fly i got told that i would be far enough away at over 2 /12 miles
However when i tried to fly over 2 1/2 miles from the airport i got this

then i got this and when i tapped yes i got this can anyone tell me why i was not able to use the self unlocking please.
By the way when i checked online i found out that the whole of the island is now a no fly zone but how does my Mavic know that ???
Thank you

Was your device connected to the internet when you tried to unlock Authorisation Zone?

1009 is a connectivity error.

1 Like

There are two NFZ databases in the GO4 app and one in the aircraft.

They are continuously updated.

1 Like

No, I was outside and i use a i-pad mini 4 with no internet access at all

Then theres your answer. You would need to use a hotspot on your phone so iPad has internet.

1 Like

Well thats what i was thinking but my mavic has not been updated since i bought it over a year ago and as far as i’m aware the new NFZ over St Marys is fairly recent (last few months), i’ve had a simmiler message in the past but have always been able to override it

Ah thank you but why have i been able to override in the past with no internet access ???

Your not overriding when unlocking a NFZ, your requesting an unlock which comes from DJI servers after checking your account details.

Was it a NFZ you unlocked before or just acknowledged class D airspace or similar?

1 Like

Have you updated the app or downloaded again? It has databases as @PingSpike mentioned.

It will also pester you to update safefly database when connected to internet.

No i have done neither

Ah fog beginning to lift, sorry for incorrect terminology, not sure what it was before just remember being told on own head be it or simmiler,
but does that mean that i can unlock any NFZ if i ask dji ???

Are you sure app store has not being updating app automatically when you connect iPad to internet?

If you open Go4 on your iPad, enter device, camera view then three dots to bring up menu, tap three dots in menu and open about page at bottom.

What app version are you running?

What basic and precise fly safe database version is listed?

ipad also has not been connected to internet since i bought it last july and only to register it, it’s only used with my mavic.
I will have to look at your other questions tomorrow as not at home at the mo,
Can i turn of the NFZ warnings compleatly or will i have to do it each time asked, problem is i have no way to connect to any internet when out as my phone is so old ???

Custom firmware can disable NFZs but if your not sure what the different zones are it’s probably best to leave that alone, it’s also not a simple process on IOS.

Here’s a good description of the different zones and how to unlock through DJI.

The zone you tried to fly in was an authorisation zone meaning you can self unlock. Restricted zones require you to submit proof you have permission to fly.

Many thanks for the link and your time, much appreciated,
i will post answers to you other questions when back home tomorrow,

1 Like

If you request permission from DJI you can download the unlocks in advance (you have to tell them when you’re flying) so you can unlock before you go. This is ideal for flying in remote locations with no mobile signal too :+1:t2:

Hi there
App version is 4.3.18
Basic is
Precise is

Hope this makes sense
Thank you Mouse.

I like this idea but reading the link callum sent the unlock only lasts a few days, some places i go on holiday have little or very poor internet access, is there a way i can do it for a longer amount of time so i can set things up from home before i go away ??.
Thank you.

Alas no, that ‘GEO’ system is completely controlled by DJI.

Well, not from their web interface there’s not…

You could always try opening a support ticket as ask them directly? You never know…

If you do, please share the results of that ticket with us :slight_smile: