P4 RTK - "Strong Interference" - Any Ideas?


I struggling to get my drone to connect to the remote unit but I now have a consistent error “Strong Signal Interference”

I have tried the following:
Using the channels it suggests
Moving from “auto” to “manual” on the channel options
Turning off my mobile phone (airplane mode)
Adjusting the antenna on the remote unit
Driving out to a field and testing it there (rather than at home)
Patching the latest firmware for the drone and the remote unit
Downloading the latest version of the app from DJI (the relevant APK)

I have time I change channels (and relink) I get the same error straight away. Any suggestion?

Picture of the error/set up below.

Thanks in advance

Try resetting the RC.

Is the drone sitting on a concrete base with rebar running through it? That screws with my P4 and P4P compass and everything else.

1 Like


Thanks for the replies

I was out testing in the field this morning and, I am getting somewhere …slowly . Its not yet working, but its getting there. I have been through a LOT of permutations (I think the android handset/ firmware combo was a big part of it) .

Long story short - I am now connected to drone, the interference issues has been reduced/disappeared (as long as I dont do it indoors or in my garden - that still doesn’t work) - I have calibrated it, and it now says

"unable to fly"

GPS is good, compass is good - RTK is weak (I dont think that matters) - I tried several fields and drove about an 30 min between them (so about 2 hours of driving around in total). Any idea what would cause that? I have tried on fields, grass, soil, tarmac, concrete

I have not been able to start the motors - i.e they just wont spin (I tried pulling the handles down,). The drone is activated and registered to me.

Now the firmware/hardware issue is solved I am hoping it will me something simple - like a switch!



If you click on that message does it give you a list of statuses?

Overall, compass, IMU, Vision, etc?


Thanks for coming back to me.

Everything was calibrated - and it looked ok. There were no errors reported and I could not click on anything to show an error. I am using the DJI Pilot App - screen shots below.

I had tried moving locations, different sufaces, numerous reboots, (I calibrated it about 3 or 4 times in each location)

What’s this? And is it the cause?

Hi - that is the RTK signal ( think!). The drone has RTK capability, but I am not using it - just using GPS, and its in that mode.

This was an issue with the drone - changed it and it worked

1 Like

You changed the drone @rob585 ? :thinking:

Yes - got a new one…actually, tested out three more.

Turns out there there was a problem with a batch of drones (they could see it was a batch from the serial number). The first three failed, but then got a fourth, from a different batch and it worked fine, no issues at all.

Really good service from the shop - very good of them to test them all out and see the issue.

1 Like

Wow, good to know, thanks for the update!

A rare thing we hear these days. Can you share the name?

Sure - I wasn’t sure if that was approved/allowed. Its a company called Drone Safe.

Not only did they source 3 additional drones in one day, they also spend more than 1 day testing them, and they also arranged for a next day delivery (no a saturday) at no cost to me. At one point, there we just going to drive it to me directly (3+ hours away) as the cut off time for the courier was so tight.

Really good service.

Drone Safe Store - UK DJI Official Dealer

1 Like