Quickshot issue Question Air 2

Has anyone had this happen and if so has anyone got a reason?
Air2 was flying perfect, fetched it back towards me and thought I would try a quick shot or two. So set it off to do an asteroid I think it’s called (GLOBE THINGY) It did that no issues, then sent to circal round us and it was doing perfect BUT got to approximately 80% complete and started to wobble, then it just set off like a headless chicken backwards dropping down at a fair rate. I pressed pause and took control and landed straight away. Checked round the drone for anything obvious but nothing. So took to the skies again and it was perfect. Now the weird thing is it didn’t record any footage of it circulating us at all. Other than that all seems OK.
It does tend to disconnect for very short spells randomly even when it’s close to me at home on the park or in the middle of the countryside at a farm.
Thanks for all if any advice…


1 Like

Cant help on your issue, but I’m pretty sure if you cancel/abort a quick shot nothing is saved (even the part it did)

Oh yeah, that would sound like the reason for having no footage. Thanks for that. I never usually use any quick shots, in fact this was the first time so it’s a learning curve…

Have you looked at the flight logs, maybe something in them will give you a clue?

Use Airdata

1 Like

Thanks very much for that. Can’t find any obvious reasons, no errors or warning.

Thanks for the info. Didn’t know this was available.

If you click the share button at the top right and post it on here someone can have a look and see if there are any issues, you never know you could have missed something

If you can see where I was doing active track it is very wobbly then you can see as it get near the end it just took off backwards. Having watched the flight on here I remembered that I tried to kill the motors as it got low to the ground and that didn’t work, that’s when I hit pause and held return home as last chance…
The line that has the 50% on it is where it went stupid.

Its problems happen whilst on the active track, it then loses altitude after you tried the emergency stop mode!

Luckily for you didn’t quite pull it off!! image

It is like it lost the track object but didn’t then know what to do, so shot backwards :man_shrugging:

Maybe @OzoneVibe might be able to shed some light on the problem :wink: :+1:

It was a strange one. Like I said I don’t usually use anything apart from on sticks flying. So will see what happens next time…

Thanks anyway.

I most say. I had no issues at all with mine. Rock solid.
Only issue was that time I miss calculated how far I was and how little battery had. But that was my fault.
The original mavic air 1, did some weird things while using quickshots.