Recording problems ..... is it just me?

Anyone had problems recording to their SD card.

My Hubsan 501s sometimes records & other times not.
Card clean / freshly formatted / fully fixed in.

Any advice?

Formatted in the drone or on PC?


The pc wasn’t happy recognising the drone formatting.

It seems to work sometimes not others.
Really odd intermittent error.

1 Like

I would recommend only ever formatting on the drone. There can be odd nuances, hidden files, etc that the drone expects.
But, you’ve tried that without success … so uncertain as to what else you suggest.

Tried a different card?

Thank you Dave,
Appreciate your advice.

I have been using 2 different micro cards.
One a few years old 32Gb & one brand new 16Gb.

I’ll try again tomorrow, formatting them both again in the drone.


1 Like

John, what resolution is the drone recording in?.
If its a high resolution, then you need a fast card, using old cards that are not fast enough could be the problem.
I always use Sandisk Extreme, never had a problem.

1 Like

Found this, might be of help.

Unable to copy and paste it so here is the link.

Key points are that your SD card should be 64GB or under, speed class 4 upwards and formatted exfat.

It also mentions you need to check allocation unit size is set to 32KB and volume label must be left blank.

1 Like

Thanks Chris,
Just checked, it is 1080p HD.

Thanks Callum,
Very helpful.

Much appreciated.

John, How did you get on at Flixton the other day?

Thought I had formatted in the drone but hadn’t.
Now can’t find any way to format in the menu.

Tried the formatting in the computer under ex fat32, with 32kb but no joy.

Might need to buy a better card!

Had a great time.
Gusty winds were scary.
Put SD card in wrong slot, so no pictures :face_with_symbols_over_mouth::rage::face_with_symbols_over_mouth::cold_sweat::cry::cry:
There is an SD slot on transmitter, Which I used, only to find out that slot has no function. :exploding_head:

Put the SD card in right slot on the drone, and mostly does not record.
Got a few pics/vids but nothing after that.
Tried reformatting under ex fat32 but nothing.

Maybe rubbish card

I’ll get a better one on Monday.

They said I was welcome back, so as soon as the recording is straightened out, I’ll try again.

That Formatting sounds a right pain in the R’s !

1 Like


Putting it in the right slot also helps :flushed::wink:

Sounds to me if now might be the time to buy a mp2 …:rofl::rofl::rofl::rofl:Go on you know you want to…:wink::wink:

1 Like

Well Tony, he’s had a taster of my Mavic Air, got to be a lot easier than pissing about with media cards !.
Anyone got a Mavic Air they wanna sell to John?.

1 Like

We need to use the collective power of the grey arrows to…er persuade him,to go to the dark side…:+1::+1::rofl:

“Feel the Force John”

1 Like

Indeed once again John,“feel the force” !!!