USB stopped working after soldering

By keeping hold of the boot button when plugging in.

Ok. If it isn’t the cable or pc, its the fc is bad

Have you tried taking the receiver back off and unplug the vtx so its literally just the board?

Already tried that, nothing. Guess im done with drones then lol

Just get another fc. I went through 3 when I first started :laughing:

Cant afford it.

Try reinstalling the drivers from scratch, windows might have updated them automatically or something silly

Did you try desoldering the receiver and unplugging the vtx so it’s just the fc before plugging in the USB?

I killed 2x £70 flight controllers when I first started. :rofl: it’s painful but life moves on lol

1 Like

Be nice to have that kinda disposable income.

Wasn’t disposable I didn’t eat for 2 months :rofl:


Thats what fpv really stands for Food Vs Playtime lol


Just felt the chip after leaving it plugged into usb for 10 mins and it’s cooking, seems it’s fried :man_shrugging:

Man I’m tired, that acronym doesn’t even work :man_facepalming: lol

It is an expensive hobby. I’m down to my last 4 motors, I use bust props by bending em back just this minute repaired my camera with superglue.
You’re gunna break things regularly. Stick at it :+1:

Id happily buy another if I could afford it but I can’t especially if they break this easily.

I have an F4 fc you are welcome to borrow if it helps at all Alex? Not as fancy as your current F7 but would get you up in the air at least

That’s the problem. We still don’t know how it broke. It could happen again.

Exactly that I don’t want to spend the cash and instantly fry it

Thanks for the offer but I’m worried I’d just kill your FC in that situation