Camera settings no longer saving on DJI Mavic Pro

None of those have ever changed between uses for me, however long in between.

From the app, have you tried performing a camera reset?

Yes I have done a camera settings reset and changed them to the ones I wanted, it made no difference, the settings were always saved since I owned the drone, but that is not the case now as far as camera and video settings are concerned. as all other settings remain the same it leads me to believe the camera settings must be saved somewhere else but where is the question.

1 Like

As for the other settings, I don’t recall, but I do recall someone getting 4:3 instead of 16:9, but again I don’t recall if that was just on the display of the actual recordings.

I’ll have a rummage and see if I can find it.

Whilst subjecting my brain to some additional racking, I now seem to recall that was an issue when switching between photo and video, or the other way.

Your photo settings stay constant OK? ISO, manual/auto exposure, manual/auto focus.

I believe there are 3 memory locations

  • App
  • AC
  • RC

which settings Saves to what seems to be a mystery to the world . :pensive:

Yes iso remains on auto as does exposure and auto focus, I have just swopped the SD card for another one to rule that out of it. The card that was in there is a brand new one sanddisk extreme as I was in Wales doing a shoot and when I got home to get footage off drone PC stated card needed to be formatted and I was unable to get any footage off the card. The drone recorded just fine the last time I flew it so yet another strange event

This I’ve seen people suffer from before. Sometimes (not always) from turning the drone off before stopping recording.

A solution has been as follows (provided you’ve not reformatted the card) …

  • Put the card back in the drone and fire up
  • Use the app to see if you can still play that clip
  • Use the app to download the full-res version to your phone … transfer to your PC.

Also had this issue when you remove the card to extract the footage and not directly plug your drone into the PC.

I NEVER connect my MP to the PC … I ALWAYS remove the card and put into the PC … I’ve not had this happen in 5 years.

Also - rather obviously - you can only get this message if you insert the card into the PC.

1 Like

I will remember that in future, I ended up just formatting the card tested it afterwards and it was working fine, but replaced it just in case. When I next am able to fly the drone I will do the camera settings again at location and see if they then remain the same the next day, thanks for all your input.

1 Like

I’m the opposite, Always plug my drone in and never remove the card. The chances of leaving it in the PC are high and the risk of not having it on a flight would be annoying. (if you don’t carry a spare)

Yes I always remove the card and put that into the PC and always format the card while in the drone, I never have had the problem I did on that day ever before

1 Like

I want to use my drone batteries to fly, not to cause my drone to heat up excessively whilst I copy the files.

Even with never connecting (other than for copying the onboard DAT files, there is no other way), I’ve had a cooling fan failure that was almost a total strip-down of the MP to replace. I really don’t want to do that again.

Do you never take the SD cards out of your DSLR and plug that into the PC to copy the files too?

Do you not carry spare cards? (Not that I’ve ever needed the one I carry, myself.)

1 Like

I’ve got spare cards although I’ve not put them in my new Man-Bag yet :upside_down_face:

Again I plug the camera straight in which opens up the EOS utility program for downloading the shots.

I do the same with my Canon 7D and only because of the risk on damaging the pins putting in the compact flash card the camera uses and for no there reason.

1 Like

Blimey. Last time out I took over 500 RAW … that’s too slow a process over USB compared to popping the card in the laptop.

LOL, My last wedding was best part of 1600 RAW. . and to be fair it didn’t take to long but, then I was probably doing other things during that time. :slightly_smiling_face:

I say RAW, Shot in CR2’s these could be smaller RAW’s than Actual RAW’s? ( I know what I mean) :joy:

Just a thought from a complete amateur at this subject, but have you tried contacting DJI and explaining the problem?
If the settings are saved somewhere I would have thought they would know where that would be, and they might even have heard of this issue before?

I have just sent an email to support and will wait for any reply

1 Like

I did an online chat with DJI and got nowhere, just wanted me to do all the things I have already done. Got a reply to my email to them, it sounds very much like the app saves some of the the settings but not all of them.

Thank you for contacting DJI Technical Support.

Regarding your inquiry, we are so sorry to tell you that the APP can only save part of the camera settings, such as exposure compensation, resolution, and format. As for the photot/video mode and the like, will automatically restore to the default. The parameters that cannot be saved on the camera need to be set by the user.

Sorry for all inconvenience caused to you.