Camera settings no longer saving on DJI Mavic Pro

Question where are the camera settings saved on the original mavic pro? I have owned my mavic pro since new and the camera settings I set were always there every time I used the drone. That is no longer the case for some reason.

When I connect the drone to the controller but without starting up the motors, I set the photo and video settings as I like them. Turn everything off and an hour later the settings are still as I set them. Try the next day and they have all gone again, yet all other drone settings such as return to home height etc are still as I se them.

I have reinstalled the app and also the software for the controller and the drone but this has made no difference. Anyone else has the same problem and if so did you find a fix.

Which firmware version is on the Mavic Pro @Davesworld ?

And which app are you using to set the camera settings? Litchi? GO4? A.N.Other? And what version of the app too please :slight_smile:

I am using the latest DJI Go 4 app that was last updated on the 21st September 2020 4.3.37 drone on latest firmware 01.04.0500

Are you using the same phone each time?

Or are you swapping between a phone and a tablet?

My train of thought here being that some settings are saved in the app (on the phone/tablet).

I don’t think anyone ever did put a list together of what’s saved where? :thinking:

I was using a Samsung S7 that was only used for the drone, I recently started using a Samsung Galaxy A20 e once again just for the drone with the same app installed on it, I will try the other phone again and see if I still have the same problems many thanks Dave

Going back to the S7 has made no difference the camera and video settings are still not saving. If settings were saved on the drone would it not need some sort of battery to keep its memory? just like normal cameras etc?

I’m trying to remember if there’s an onboard backup battery … coin type.

Definitely the settings remain on mine even if I change device.

If there is an onboard battery … it must be deep inside, because I’ve opened mine up a couple of times (ribbon cable replacement / gimbal cable replacement / cooling fan replacement [the worst!]), and I don’t recall seeing one.

1 Like

Scanning quickly though a couple of teardown vids, I don’t see one.

1 Like

This wouldn’t be in the RC would it Dave? Then when both are switched on they sync the settings? :thinking: just a thought.

The RC batteries never get remove, so there’s no need for a backup of any sort.

1 Like

I’ve been doing a bunch of googling and nothing!

My others thoughts would be…

  • Have you tried a different battery and having the same issues? Could be a fault with the intelligent side of the battery.

  • Delete and reinstall the app / different device

  • factory reset (if possible) not looked into this

That only has any impact on battery charging, auto-discharging and the LED.

… and …

See OP

1 Like

I’m all out then :weary:

The MP has been out long enough, you’d think someone would of posted something somewhere on the web wouldn’t you, literally can’t find a thing.

Completely random and clutching now but … :joy:

It doesn’t save the settings to a hidden folder on the SD or onboard memory.

C’mon, least I’m trying here 🤦🏽😂

Just to be absolutely clear here, you’re applying the settings using the S7, powering off the drone, then when you turn it on again using the exact same S7 phone the settings have reverted back to defaults?

If so, my next step at this point would be to re-flash the firmware on the drone.

Isn’t that what he says he’s done?

I mean, there is no drone software, only firmware.

Up date, I have three drone batteries and the results have been the same. Use the app to change the camera settings while connected to the drone. Turn everything off for a while the camera settings I set are still there. Do the same a few hours later and the camera and video settings are gone , but not all the other settings that were also set using the app such as return to home height etc.

I also have the app on the phone I use daily; this phone has never been connected to the controller. I connected this phone this morning with the controller and switched on the drone and all settings were there except once again the camera and video settings. This leads me to believe that most if not all settings are not saved in the app and could be saved in the controller. But why then would the camera settings revert back to default and not all the other settings that were changed.

Google play store app is v4.3.37 but if you look on the DJI download site the version is v4.3.46. I have used DJI assit and reinstalled the firmware for both the drone and the controller and that has made no difference. I have done the same with the app on all three phones I own.

A strange event just happened, I connected everything up for the third time this morning and received a warning that there was an incapability issue and I clicked update and it was showing an update was being done on the drone 01.04.0500. I have since looked using the app of the versions on the drone and controller and both are showing 01.04.0500.

I will check again later today to see if that has made any difference, but both were reinstalled using the DJI assistant a week or so ago and today was the first time I received this warning. I last flew the drone four weeks ago and it performed well, it was only when I downloaded the footage when I noticed the camera and video settings must have changed at some point.

I do not believe any settings are saved on the SD card; most camera minded people always format their cards after they use them each time.

1 Like

Can you give us an example of a setting which doesn’t save?

I’m beginning to wonder now if you’re chasing a ghost?

I set the image size to 16.9 and landscape, it goes back to 4.3 and normal. Video settings I set to 2.7 k, mp4, and pal, they go back to 4k, mov and ntsc,