Can't bind new Air2s to my account/controller

Apologies as I suspect this question has been posed and answered before but I haven’t found it. Just got my nice new Air2s to live with my Mini 2 and all went well until going into Account Management to bind the device and controller to my account. Having paid up for Care Refresh I want to make sure I am covered for Flyaway however unlikely. Every time I just get an error message once I’ve clicked the button to bind, basically telling me to turn everything off, close the App and start again. Three failures suggest that isn’t the solution so HELP please. :thinking:

Are you trying to use one controller for the Air 2S and the Mini 2?

No, it’s the one supplied with the drone.

1 Like

It should be already paired to the drone, if you’re trying to link to your DJI account I don’t think you need to press any buttons on the drone or controller, I know I didn’t have to.

You need to bind the controller to your DJI account

This explains it

Yes I don’t remember doing it for the mini2. On this however when I turn on , controller, drone and app, and look at my profile it’s just the mini. I can then go into account management and select the air2s option which tells me that I need to bind but when I follow the prompts it fails. Looks like I will have to trust myself to dji support.

Yes that’s exactly what I was doing and it failed every time. I’ll sleep on it and double check it again tomorrow. Thanks for the link though As it proves to me that I haven’t totally lost the plot. :grinning:

1 Like

Are you using the same DJI account as the mini 2?

You gave them the correct serial and email

It could be just a server error and it’s not updated with your new details for the air2s yet

Have you tried another device?

Happened to me a few weeks ago DJI came back to me saying it was a problem not of my making, all went well after that, best of luck :slightly_smiling_face:

Thanks after sleeping on it I will now double check everything and try using my pad. :pray:

1 Like

Thank you this will be Plan B :grinning:

Just a quick update - I have thrown the problem back to the retailer (LCE). What we have identified so far is that the Firmware version is incorrect which it refuses to update and continually insists the firmware is up to date. My feeble brain has also noticed that my Profile details on the App always just refer to my Mini2 which is up to date. So another frustrating wait and potential return looms.

Out of interest what version is the firmware?

09.09.0903 which looks like rubbish to me but the app keeps telling me it’s up to date which it isn’t and it won’t update. Looks like some form of data corruption to me. Thanks.

Have you tried using DJI assistance to check and update the firmware

You can refresh the firmware, upgrade and downgrade using this procedure

I know I have written this for the MIni 2 but it should work for the Air2s, worth a try

This is the latest link to DJI assistance

https://dl.djicdn.com/downloads/dji_assistant/20220124/DJI+Assistant+2(Consumer+Drones+Series)+2.1.9.exe

1 Like

interesting this is a list of all the released Air2s firmware

Thanks so much for the info. The firmware details prove to me that whatever firmware is loaded it isn’t the correct one for the AIR2s. I’m guessing there is corruption(files that is) involved as I can’t see any Mavic firmware with that reference. Thanks also for the other suggestion but as this is new I don’t want to be accused of causing the problem myself plus if I’m honest it looks right at the edge of my competence level. I have give the supplier LCE until next Friday (the 13th) to sort it otherwise I’ll be sending it back. :crossed_fingers:

Ok I do understand, you could try just downloading the Fly app, don’t do the mod as I suggested but just connect the drone to the DJI assistant to see what it says
You can’t do any harm

It may also help anyone else with the same issue

This is the release notes for DJI Assistance

Did follow your link, but I am a Mac. user. I didn’t find an iOS version. Don’t worry on my behalf But I will report back on progress, or lack of it, for the benefit of others.
Since starting this reply I found a DJI Forum and there appears to have been a major problem with a lot of the earlier models which ended up having to be replaced. As this was an ex display model (never flown) I wonder if this is like them. They all had to be replaced.
Thanks again for your interest.