Can't synchronize flight data


Been sychronizing flight data from P4 through DJI GO 4 on my iPad via Airdata no problem. Got my P4 Pro+ today and now when I try to synch I get the message ‘Synchronizing Flight Reords Failed’.
Logged into WiFi and connected to network fine, logged into DJI fine - mind you, when I hit ‘Update’ I get the message - VersionV01.02.0000, followed by the text Current Version. When I hit check for updates I then get the message - Note - Failed to check firmware package. Check your network and retry?

Any suggestions?

I’ve not been able to sync flight records with DJI for a good few months now on my CrystalSky. I get the exact same error, in the blink of an eye too. I did try some log debugging, saw some issues re failed handshakes which explains why it fails in the blink of an eye.

I’m guessing DJI turned something off or that something has expired?

I run an old GO3 app for the Inspire and a few different versions of GO4 on there (mixture of old, custom, and old+custom) for the Mavic Pro. The CS is also on a really old firmware version too.

Not an issue for me really as only ever sync to AirData these days anyway so I’ve not spent any time looking in to the DJI issue.

Sorry that doesn’t help, but you’re not alone in the sync having stopped working!

1 Like

Well I’ve just installed the current version of DJI GO 4 on my GL300E, hasn’t booted yet though, just a backlit blank screen. OK, re-booted and it’s starting up. All done! Synchronised via DJI GO app and Airdata now contains all of my records - P4 and todays flight with the P4Pro+

i found that when i first started flying my MP i was using my Galaxy s8 then switched to the moverio glasses all my flight data from the s8 has vanished from dji it allso when uploading video and pics to my phone it tells me there isnt enough memory

Then it definitely sounds like DJI have updated something that has expired on older firmware or app versions…