Charging Issues

Just got a Sky RC T200 charger, which worked well for a few days, but now I am struggling to “balance” the LiPos (I have 2), either to charge or to storage. They’re both 2S one 3000 and one 4000mAh. The charger shows the two voltages from each cell. And if I set the charger to LiPo balance or storage it just never finishes. Tried 1Amp, all the way to 4Amps. I’ve set the time out to around 4 hours (240m). The batteries aren’t hot in the slightest, and the actual Amps during charging to go low low… (i.e. 0.1/0.0).

With the 4000mAh hard case I used in the car and ran it low, it charged up to around (I think from memory 4.2V per cell) quite quickly, but the second cell shows around 4.11/4.13, and the 1st 4.20/4.21. Seems not to be able to balance. I’m new to LiPos and read a lot around safety, etc, so trying to be careful. I get options for Amps and the number of cells, and have options for Charge, Auto, Discharge, Balance, etc. Any suggestions please, as neither of the batteries can complete balance, or storage mode atm. DO I need to balance charge every time, as there is a normal charge too?