CrystalSky + Mavic 2 Pro

Yalp app (fake Google store) is trying to update the Go4 app to the latest Android version on my CrystalSky… Should I let it? Has anyone done this? I really want to use the Mavic 2 with it.


The ‘regular’ Android app won’t run on the CS.

Why not update the built in one?

I tried updating the CS last night said that I had the latest firmware.

Ah right, no… you don’t need to update the whole firmware, just the app itself.

I forget where the option is, but in the GO4 app on the CS itself, there is an update option there just just updates the GO app, not the entire CS.

Or there was a manual download over here:

But yes, the update option is built in to the GO app somewhere, I just can’t place it off the top of my head.

I guess it doesn’t matter. I’ve tried to activate the Mavic 2 Pro and I just get error 400. Contact DJI Support.

From what I can see on the internet, it may be stolen!

Where did you buy it mate?

eBay… I’ve already put a return request in. It was sealed and 100% new. Seller has 100+ 100% positive feedback.

Good news (well for me at least)!. I had my first flight tonight with my new bird. How beautiful the display looked on my Crystalsky while flying compared to the original Mavic! I just need to view the footage on a PC as I noticed that the Image didn’t look totally sharp. That said, it could have been the failing light and auto mode.

Gave up with my first 2 Pro and DJI slowport… Totally useless. Couldn’t advise why I could activate my 2 Pro after 3 days of trying. What’s the point in having a call centre in the Philippines with no technical information at all just taking messages and waiting for China to respond!

To update your GO software from the CS… Open the “GO” app.

Then click “ME”, then “Settings”, then “Check for updates” if it finds something your can download it … as of 17/10/2018 latest app on the CS is 4.3

Downloading firmware updates or activating on the CS. Forget it it doesn’t work. From what I’ve read a lot of Android user are having similar problems.

Solution is either use an IOS device or the Assistant 2.0 for the PC.

1 Like

I tried using iPhone as well. Wouldn’t activate. That is when I gave up and sent the last one back. This one works fine. Activated direct from CS within a few minutes of unboxing. That said the CS can’t update the 2. Had to do that by Assistant. Kept getting network error!

2 things…

If you’ve not already, you should consider manual focus. Set it to Infinity and forget about it. Just be aware the icons are mixed up on my app. I need to touch the macro type symbol to focus to infinity.

Second if you shoot in DLOG-M or HLG there is no sharpening applied in camera and can look a bit off in display.
To be honest it’s an absolute nightmare to work with and I’ve found 8bit with +1 sharpening and -1 contrast looks great.

I’ve got 6 flights worth of decent 10bit footage I can’t do anything with.

I’m Android and never had any download/update issues over the many versions in the last two years.

1 Like

did you manage to update the firmware on the mavic 2 over android ?

maybe some devices work and some dont ?

alot of people moaning about it over at the dji forums

MP - every time - three different devices over the 2 years.

Perhaps this is just a M2P issue? M2Z too, perhaps.

Sorry - hadn’t realised this statement was M2P specific - it just read Android realated.

I’m finally updated and with latest firmware. Had to flash the M2P from Assistant.

DJI need to stop using the connection issue notification for every issue. I never have any connection issues… Just DJI problems!

1 Like

Yes dave, only a problem for the Mavic 2 pro/zoom … not that dji will admit anything LOL

1 Like

My original MP updates easily and without fail every time.

1 Like