Dji download maps to RC2

Hi i am trying to download offline maps on to rc-2. I have wifi connected. I pick an area to download then i press download, asks me to name it, which i do. When i go to see if it has downloaded it is at 0% and i have left it for 10mins, i do notice beside the % there is an icon with a pause or play symbol i have pressed both symbols and no download.

I have read how to download and youtube, but cant find if these symbols have a part to play to start download. Thanks

Is there an SD card in the controller and is it formatted

Hi I have a SD card in controller, formatted card on pc. I have full fibre internet 900mb/s download speed.


It’s always best method to format in the device its being used in

Worth a try

Logged in to your DJI account?

Make sure in your profile on the RC2 that you have changed the saved location to the SD card and not internal memory, I was doing the same.

On home screen, select PROFILE/SETTINGS/STORAGE on the left, make sure SD is selected as storage location, it will move any files to that SD card straight away

are you using spaces in the name of the location ? Maybe omit the space ?

Hi been in touch with dji, had to reset controller. Controller is connected to home wi-fi, and account is showing on controller. Been told by dji take out sd card and go outside with drone and controller to see if i can download map that way. just charging batteries up more incase have to get in touch with dji again. thanks for helping everyone. It would be good if you could download maps of a data base and import it into controller. do i really need the maps??

Only really need them for places with no signal, or if you forget your mobile to tether up to before flying, they also help with pre planned WayPoint flights

Thanks for all the help. Eventually I reset my router, and password everything. Then it works. Still think a database would be good idea. But thanks. Can’t wait to try it, to windy. Lol

Is there a way to download a bigger area to the SD card in the controller?

i am not sure, i have made that downloads are meant to save to my sd in controller which is 256gb, but says i only have 19gb free, no idea to be honest, sorry i cannot help,i am new to this type of controller

As above, you are saving to the internal storage, not your memory card, look at my previous post above on how to change the storage to the sd card

Hi i changed it to save onto sd card, but still says only 19gb available. Does the controller have a max sd card size it can take? i will have to check i am sure it is 256gb might be 512gb v60 or v30

Not too sure, I have a 128GB and all mine are on the SD and not taken up much space

Hi. I downloaded some offline maps - approximately 20 - and the RC2 was still showing over 17gb capacity remaining but when I tried to add another I got a message saying that maximum server capacity was exceeded and telling me to delete any unwanted maps to make space. I’m not sure why - do these maps also get backed up onto some dji server? Thanks

I came across the same issue, had a quick google, can see people reporting the same issue for years, but cant find an explanation yet,

Thanks Paul. Glad to hear it’s not just me who’s encountered this but seems strange nonetheless.

I got in touch with DJI usa to get the answer for “maximum server capacity was exceeded” when you download maps. I live in the Uk and dji uk is closed, but i changed location to usa to speak to them. Here is a copy of the transcript i had:

HI, there

when i download a few maps i get this message “maximum server capacity was exceeded and telling me to delete any unwanted maps to make space”

i have rc-2 controller with sd card

Thank you for description

Please allow me 1-3 minutes for checking, please hold online. Would that be ok?


Thank you

Also could you please provide me a screenshot as reference?

i dont have one right now, sorry

Thank you, I got it

it is when i download maybe 20 maps that is when i get it, i am trying to download different areas that i am going to fly

Thank you, may I know the capacity of your sd card?


Thank you, kindy please wait me for two-three minutes, I am still checking

Thank you for waiting, may I know if your sd card get stuffed?

stuffed ?

sorry dont understand “stuffed” ?

Sorry, no offense intended, I wondering this word can be used as a verb form to mean that the sd card memory is full

it has about 110gb free left on it

Thank you

it has not been used for anything else, new and formated

Sorry, may I know is your sd card memory full?

it has 110gb free left to use

May I ask whether you chose the SD card or the internal memory as the storage path?

sd card

Could you please restore the remote control to factory settings to see if the problem can be solved?

i have tryed that

Kindly pease wait for the last minute again, I am still looking for a solution

Thanks for waiting

The upper limit of offline maps download is not capped by the token memory size but by the tile count of the maps

The only solution is clear cache for several offline maps and then download again.

That’s interesting. Maybe it’s a licensing issue on the maps? Thanks again for making enquiries and sharing the DJI response.