DJI FPV Inconsistent Firmware in battery

Hi.

My FPV is hacked with the drone-hacks solution. The firmware is the 01.02.0000.

I was flying today. All was well. I landed because battery was at 20%.

Plugged my second battery and the message “inconsistent battery firmware” message flashed on the goggles.

I tried reflashing the drone from drone-hacks app but that didn’t work. I was able to reflash to 01.02.0014 then back to 01.02.0000 … but the drone hacks app would then never detect the drone!

The only I found to align the drone firmware and battery was

  1. re-flash/upgrade to latest firmware 01.02.0015 using DJI Fly app
  2. switch off goggles & controller.
  3. connect FPV to Windows
  4. using drone hacks app. downgrade to 01.02.0000 via 01.02.0014
  5. reapply hacks

I think it stands to reason if I chose to buy a 4th battery. if the drone and battery firmware didn’t match then I’d have to all the above again.

Anyone else had similar experience
Thanks
Christian

There is an element of risk in what I did though, which was using the DJI Fly app to flash the software back.

It’s very possible that DJI would force an update which closes the 01.02.0015 downgrade exploit.
Ideally, step 1) would be using the Drone Hacks app. But I didn’t have the 01.02.0015 firmware.

I’ve emailed drone-hacks

Thanks
Christian

Interesting.

I have the V1.02.0000 FW running on mine along with the Drone-Hacks patch.

A few weeks back I purchased two extra batteries from Heliguy as they were discounted. Once I’d charged the batteries I plugged them into the drone, and once booted up I saw the same inconsistent firmware message. However I was able to update the batteries from within the goggles via the drone itself. No issues thereafter.

I know many have had issues with new batteries, some see the FW warning message but no option to update, others see no message and just the solid red rear LED’s. These issues seem to be isolated with batteries sold in the Fly-More pack with the charging hub, and it has been speculated these have been provided by a different manufacturer to the ones originally supplied when the drone was released.

1 Like

You can access a FW archive from within the desktop APP, or alternatively go directly to the website linked in the APP and download the firmware locally.

1 Like

http://dankdronedownloader.com/DDD2/app/index.php

2 Likes

The last time I was out flying with @Howard78, he had an inconsistency of battery firmware. Fortunately I was able to attach the battery to my drone and do the update.

No idea why the update would not work for @Howard78.

We are both on the 01.02.0000 firmware with the DH exploits.

:person_shrugging:

Mine was triggered by a brand new battery.

Think probably it was due to the very long time without being connected to the app

1 Like

Interesting conversation here.

Initially, my FPV was on 01.02.0020. At that point, I tried the drone hacks but I got in a pickle because the I’d had the Goggles & the controller powered on when doing the rollback flash/hack procedure with the drone connected. All that resulted in a message on the Goggles saying “Cannot fly, drone not bound to phone number”

Panicking that I’d bricked the drone, I then used the DJI fly app and reflashed to 01.02.0015. Which fixed the problem.

After Goggling a lot - I think attempted the Drone Hacks again. This time, I did it without the Goggles & Controller powered up. I was able to flash 01.02.0000 via 01.02.0014.

Perhaps, the “inconsistent battery firmware problem” was because it was last used when the drone was flashed with 01.02.0015 - but yesterday when I got the problem the drone was on 01.02.0000 ?

My worry is I get this problem if I buy a brand new battery.

Yes very interesting thread. I use the fpv Drone with original release software including goggles. I will not be Updating. I have DH applied… I would like another battery but resisting because of this potential problem, any one friendly with YouTube Mad’s tech who may investigate?

Using the drone-hacks app, I was unable to re-flash my FPV drone from 01.02.0000 to 01.02.0000.
The app said the anti-rollback prevented me (?)

I would’ve thought it would work, flashing from and to - same firmware.

Because that would’ve been ideal and best solution. No DJI Fly app :slight_smile: Not changing the version of the FW on the drone. Just re-flashing with same FW with the new battery.

However, for new batteries - if I get this problem. Using the drone-hacks app only.

  1. Flash to 01.02.0015 or 01.02.0020
  2. Re-flash to 01.02.0000 (downgrade)
  3. Apply hacks.

That does come with some friction and isn’t 100% pain free.

I’ve tried emailing him in the past on YouTube. Perhaps, he missed it but my email went unanswered.

I sent him an email earlier, probably not somewhere he will find it? Wait and see.

Looks like one of those is versions is incorrect?

No. It’s correct.

At the time my current FW was 01.02.0000 and I tried re-flashing 01.02.0000. But that didn’t work via the Drone-Hacks Windows app. Hence why, I then “upgraded to 01.02.0015” … to then downgrade again.

I found the whole procedure to be a lot of friction when all I wanted was to refresh the drone with with the 01.02.0000 firmware in order to fix the “Inconsistent Battery FW” problem.

1 Like

Ah - the “from … to” fooled me. “re-flashing” the same version I get. :+1: