DJI V2 Goggles 😭

Sorry to bring this up again as I’m sure everyone must be fed up with the whole Dji goggle thing.

Iv just received my DJI V2 Goggles and I’m really struggling to get the up and running!.

Says in the Goggles the firmware is V01.00.0600

Tried the Josh B walk through but when I enter the dji account on Assistant2 it displays V01.00.0606 and V01.00.0604 and not the one everyone else displays on YouTube.

It also says at the top of the page my current is V01.00.0603 so I have no idea what is going on…

Any help would be greatly appreciated as I’m at the end of my tether with the whole FPV thing, wish id just stuck with the camera drones :unamused:

Cheers

Nick

Which firmware version do you want to install?

TBH any that will let me use them …lol

But having researched this to death, folk are saying an earlier version 1086 i.e the one Josh B put out works…

But the 1086 version doesn’t even show up in my DJI Assistant 2 ??..

I had a big issue with the googles and the firmware update. Took 3 days to resolve. Was trying to do it through the assistant 2 and constantly failed. Ended up trying the fly app again, about 3 times and eventually it worked. Restarting phone, restarting app, restarting headset in different sequences, can’t quite remember which one worked.

Cheers for the info mate, Im not sure how you link the goggles to the fly app with out the drone ??

But that said Ill give it a go later, if you have anymore thought on how you Reg them can you please let me know…

Cheers

It’s a point, sorry- hadn’t clocked it was just the goggles. There is a usb out port- USB to phone? unlikely. If you weren’t quite so far away I’d bring it up and we could sync with my setup. Hampshires a bit of a schlep though…
The goggles have got to sync to something remotely ie they have the hardware to do it - not quite sure whether they sync to the controller/drone/ phone or all of it. Worth downloading the app and having a go

Ok cheers mate, I have the APP on my phone as I have a mavic.

Will have to persevere, have no choice as just spent £600 on them… :rage:

I would like to reaching out as Im at the end of my tether with these bloody V2 goggles.

Iv tried all the work rounds on the net and none of them seem to work, spent an hour on instant chat yesterday with DJI who are supposed to Emailing/ringing me back ( Yah right).

I think the only way im going to resolve this is to pair them with one of the DJI drones, hence if any one lives in the Derby area and is will to help me out please get in touch.

I do have one question though which is, does it matter which order you pair your goggle/controller??.

I have already paired my Dji controller to my Protek 25 as iv been waiting for the goggles to come into stock, and if it does how would I un pair the controller.

Many thanks

This video may be of help, skip to 4:47 where he does a great job of explaining how to.

1 Like

Cheers mate, iv mailed him over some stuff.

After chatting with a few people im now working on the theory my goggles may not bind to my cadex unit due to my controller already being bind to it🤔…

Iv read you should bind your goggles first then your controller.

Thing is its been that long since I bound them iv bloody forgot how I did it…

Plus I’m not 100% on how to unbind them :man_facepalming:t2: