Eachine Nano LR3 Base config

Hi all,

Does anyone here have an Eachine Nano LR3 with the stoc config still on it?

I stupidly flashed new Betaflight 4.3 RC3 firmware to it without saving the default config, and now I cannot get the GPS to work, even after flashing back to 4.2.11.

I have selected UART1 for the GPS, and have tried various baud settings. I have tried editing the GPS settings to use both NMEA and Ublox, although I’m pretty sure that NMEA is the correct protocol.

The blue light on the GPS receiver comes on, but the yellow GPS symbol never lights at the top of the Betaflight Configurator page, even with both 18650 cells inserted.

I’d just like to compare what I have to a known good setup if anyone can help me please?


Hi did you end up getting the stock config??
I just the same thing and can’t get my LR3 running.

I have it flying, and it flies really well with the basic setup that comes with BF4.2.11.

The GPS not working appears to be the GPS unit itself, when I replaced it with a BN-180 I had in my box, it works fine.

If yours won’t work at all, what is happening? Can you arm it, does it attempt to lift off in any mode?