Edge TX

Thanks for the tip. It’s been added to my to do list.

Does anybody know how to install Edge TX on the Radiomaster TX16S? I’ve tried Bardswell’s way, RC Review’s way, and the official EdgeTx website way and still can’t get it to work. I want it to control my helicopters (yes there’s another one on the way) but there’s been no new updates on OpenTx since April last year and the only info I can get is for EdgeTx. Luckily, I made a backup of the SD card, so at least it goes back to OpenTx.
Thanks in advance

You may have already seen this site and the link to migration from OpenTX to EdgeTX

but he’s usually pretty accurate.

My TX16s already came with EdgeTX but I used this link when I updated mine.


If you use Chrome to open it and have your radio plugged in you can flash direct from the site. Alternately download the Firmware file and copy to SD Card.

1 Like

I watched loads of vids, and tried the all, all I ended up with was a screen with “Tools” on it. I’ll try this one next, thanks mate.

What state is the radio in now? I’ve recently done it. You have to “upgrade” to an “older” version of Edge first (if you want to keep your models), as they changed the format they store the files in and the most recent version of Edge don’t have the conversion tools built in anymore. I don’t know the exact version numbers.

Also I ruined my SD card recently just updating edge to a more recent version of edge. Copying everything off, doing a clean install and copying the models back worked.

Depending how many models you have it may be worth a nice clean fresh install and start afresh. I’d give yourself an evening or two.

Definitely worth it though for the touch screen alone!! So much nicer, and worth the effort.

Also I have a friends here on a very old version of OpenTX, but I’m going to do a completely fresh install, as he only has one model in there (a heli!) and he not flown for over a year, lol!

Back to OpenTX 2.3.9, seems to be OK. There’s only 3 models on it so far, but I wanted to put the FW450 and the “new” FW450 on it as well. Like you say Martin, it might be better to wipe the lot and start again, then copy the other models across (everything’s copied to laptop).
Going to have a sandwich, then try again.

Yeah but you’ll need to convert the model format from old OpenTX models, or older EdgeTX models (not sure which version they changed it). Sure their tools to convert models to the new format

Maybe the buddy there?

I did get an invalid SDCard issue if I didn’t format with the newer EdgeTX I put on. good luck after your sandwich :wink:

Well, I’ve tried it with Buddy, but after the screen tells me “You’re good to go”, I get another message pop up saying “No DFU support”? WTF is DFU support? Where can I get it, will it leave scars? Can I passit on to others? There’s no description of what it means, and although I’m a fairly smart person, I don’t know every acronym in the world of Geekdom. Luckily, I just put the old SD card back in and everything is still working, so no harm done.

DFU is a low level mode your RC can go into where things such as the Firmware or running software is available to be edited. Think of it as a level below the running operating software. Its possible you just need to install some drivers for your pc (assuming its a windows machine.)

Likely you need the “ImpulseRC Driver Fixer” to allow it to connect to Buddy. As with anything read up on the software first just so you are happy with installing it.

Thanks Jason mate, I’ll give it a try on my laptop iinstead of the big desktop 'puter, (newer and Win11 instead of 10).
Watch this space!