Firmware update

Having recently purchased my M2 zoom I went for a first flight and it asked for firmware update, when I got home I tried to do upload and it did it for the controller but kept saying ‘failed’ for the drone, repeated try’s made no difference ( this was on Android Samsung note 9 ).
After researching the internet an trying all suggestions I thought I’d load DJI go4 on my iPad and it loaded first time no problem, has anyone else found android problems with updating?
All sorted now but might be of some use if anyone else is finding the same problem ( could be just me doing something wrong as new to this lol )

There have been quite a few cases of this happening with Android devices.

Nope, never had a problem updating the MA via Android

I think this is less an Android issue than a “what else is running on your android device at the same time” issue.

I have a pretty much dedicated Android phone for my (albeit) MP, and never had a problem with the MP firmware updates, nor any of the other Go4 issues that some people have reported, over the last two years.

Yes your probably right about the other stuff interfering with the app

Failed updates on Android was a common problem on early M2 firmware and assistant 2 or IOS was the only thing that worked.

It’s been fixed so your next fw update should be fine on Android.