Has Windows 10 killed the Naza/Wookong/A2

Since the release of Windows 10, and subsequent updates, I have become accustomed of having to force DJI’s unsigned drivers to install so I can still configure my Naza and Wookong flight controller.

Last night I set about configuring a recent quad purchase (Steadidrone with Naza-M V2), and due to a recent W10 update I had to install the DJI VCP drivers again which went without a hitch. However when I connected the quad via USB to the Naza Assistant V2.40 there was no communication.

The Device Manager shows that the DJI VCP driver is installed correctly. I’ve tried different USB cables and ports. I’ve run the Windows Compatibility routine. To rule out a hardware fault on the quad I’ve tried connecting my F550 and Xugong Pro2, both with Naza-M V2’s, only to have the same negative response, even though a few weeks ago everything was working fine.

I fear this is just another example how tech luddites, such as myself, have fallen foul of those that create Operating System upgrades and hardware manufacturers that refuse to keep their utilities up to date. Rob, @macspite, ran into a similar issue with Apples iOS 14 and the DJI Groundstation APP, whereby the APP would crash when trying to access the iPad’s Bluetooth connection.

Rant time.

If a manufacturer, in this case DJI, decide that continuing support for one of their products is no longer viable, why can they not just release the SDK to the OpenSource community? This worked wonders for the 3DR Solo when 3DRobotics released all their code to the public. The 3DR Solo was released in 2015 and today there is still a very large community continuously evolving the drone’s capabilities with Opensource firmware and software releases, even though 3DR dropped the product entirely in 2018. Even the Smart Battery code was released and now you can use any off the shelf LiPo with the Solo and still have all the smart features of the original battery.

It looks like I’m right on cue for abusing my pain medication today :crazy_face::stuck_out_tongue_winking_eye::crazy_face::stuck_out_tongue_winking_eye:.


I think that as I suspected a W10 update has hosed the Naza Assistant and/or the DJI VCM driver. I tried to run everything on another PC but before I could plug in a USB cable W10 did an update. Consequently no communication between the PC and the Naza Assistant.

Determined to get to the bottom of this I pulled out a PC I hadn’t used for some time. I booted it up while disabling internet access so Microsoft couldn’t hijack it. Ran the Naza Assistant software and voila!! The Naza Assistant is talking with the Naza Flight Controller.

If I’m to continue using the:

Naza MLite Assistant.
Naza MV2 Assistant.
DJI Groundstation Assistant.
Wookong M Assistant.
Zenmuse Assistant.
DJI ESC Assistant.

To name a few, this PC that everything is running on will never connect to the internet again.

Something else I’ve noticed buried in the Windows System32 directory is a difference between the usbser.sys file. Even though on both PC’s they have the same creation date there is is difference of 1.5kB in file size. I remember when W10 was released and Naza owners started having issues DJI said to use a usbser.sys file that was created in 2010. ???

1 Like

Anyone else look at a screen, read what’s on it in full and then sit there and think to themselves ‘Yeah, didn’t understand a word of that’?

Oh, just me then :smile:

I exaggerate a tad. I know what Windows 10 is!

And for many purposes ignorance of Win10’s inner workings are as irrelevant as knowing how car engine works or a TV decodes its signals, how a mobile phone works or a microwave oven cooks food - computers, cars,TV, phones, microwaves - as long as they work we have no need to know how the magic happens. And when they get old we go and get a new one. No need to take something apart and modify it, no need to repair when a new shiny is just a few keystrokes and a credit card number away.

And them there are those of use who enjoy persuading technology to work … :slight_smile:

1 Like

I’ve been lucky so far with sorting a different receiver on the Wookong controlled S900 I bought recently. Both my desktop and laptop Win 10 machines have managed to behave with the Wookong Assistant. Both the Wookong software and firmware are at the “latest” (2016!) level.

I think I need to build a Win 7 machine and run the DJI software (Naza, Wookong, A2, Zenmuse, IOSD and Lightbridge) from there, keeping it well away from the internet after the initial build. Microsoft seem to decide on updates and force them on you at inconvenient times, DJI seem to produce updates that breal systems that were working.

I have always enjoyed using user-supported software such as Linux which discreetly notifies you that an update is available, you choose what you wish to include and when you want to do it and the process is done in the background while you get on with work. It’s a grown-up’s operating system :slight_smile:

I need to get into open-source flight controllers more and settle down for a few evenings with a PixHawk setup. THe only hassle is, that while I will have piece of kit that flies and does what I want it will be far less slick, less wieldy and integrated andlarger and more hands on than a Mavic Pro or Inspire.

1 Like

I’ve an old Win Vista / 7 that never sees the internet, with all the old DJI Assistants and some other PIC programming software. It’s easier and quicker than pissing about with Win 10.


I’ve never been happy with DJI’s PC or Mac software. Unsigned drivers, work arounds and setting virus scanners off when installing. They really need to get their act together and not supporting older stuff is inexcusable


You need the old assistant for OSX, works perfect

1 Like

That might be the one I’ve got just now. I recall much cursing and swearing trying to get it working on both Mac and pc and I finally got it to install on an old MacBook Pro. I just hope it keeps working…

I think you’ll get on fine with a Pixhawk and Arducopter, especially as you have a working knowledge of Linux. Even though the system is opensource it’s very mature and will leave anything that DJI has to offer looking like a speak and spell technology wise.

I’ve made some progress.

It would appear the last W10 update was the culprit. I uninstalled the update that was released two days ago, rebooted the PC, and now I have full comms between PC and Naza flight controller. If only it were as simple on iOS then I could carry-on using my Datalink Groundstation with my iPad.


I would say DJI have not been responsible for any of the innovations they claim they have. Obstacle avoidance, object tracking, automated filming modes, digital transmission systems, all were in use by the hobby/builders/coders long before DJI put them on their products. DJI just put it into the consumer market, and thus started a religion of devout followers. Some YT reviewers are positively evangelical.

Now that DJI have discontinued all but one of their Enterprise Systems (I don’t class the Mavic as an Enterprise product) I think we’ll start to see even more commercial users move over/back to opensource solutions such as the Pix4 and Cube systems. The upcoming ArduPilot Developer Conference looks to have many presentations which would be of interest to the Commercial/Enterprise users.

I’ll make sure to watch out for that and try to avoid it …

Well, my solution was somewhat simple - buy an old iPad 4 with IOS 10. So I now have 2 iPads - where I wanted none, quite OK with Android thanks - one iPad runs GroundStation and DJI Go but not GO4, the other iPad Pro is on IOS 13 and runs GO4 for my Mavic Air :frowning:

Where have I heard this before - oh yes, Thomas Alva Edison the elephant executioner and the promoter NOT the inventor of the lightbulb, the phonograph, the cine camera … Others did the work, he had the capital and the backers to commercialise the products and he (or his fanbois) claimed them as his own.

I get regular emails from Foxtech. They have some very expensive commercial drones with unfeasibly long-range and flight times while carrying a hefty load. There are multirotor, wing and hybrid as well as one which has enough lift to carry a petrol generator that charges the batteries that power the motors. And they all seem to run sophisticated control systems that have Ardupilot / Pix4 / Cube as the basis.

I have an A2 setup on an Octocopter nearing completion but I will dig out an old Pixhawk 2.4.8 Ihave acquired and try it on another S900. When I have the time :slight_smile:

1 Like

He wasn’t the only one to shaft Tesla, Marconi is credited with the radio but it was in fact Tesla’s and Fessenden’s work he plagiarised.

Standing on the shoulders of giants?