Inspire 1 Firmware W610_Fw_V01.12.01.54

The Results show that the inspires firmware is W610_Fw_V01.12.01.54. But this version is nowhere to be found, not even on the DJI website.
I’m trying to get my Inspire’s firmware to W610_Fw_V01.11.01.50 can anyone relate to this? I bought this drome from a DJI Authorized reseller in 2020 in the US. Have they updated the firmware so that it cannot be downgraded?

I tried to roll my i1 back a few years ago to no avail I tried everything hack patches everything has disappeared so you can’t do it I can’t remember how far I got it back on the craft but I couldn’t get the remote to go back and work the gimble if that makes sense to you I was doing it get get better range signal that was my reason DJI cut the power of transmission by half on one of the updates

1 Like

The roll back stop was in one of the last updates

Thanks. Yeah DJI has really blocked us from modding the inspire 1. But the inspire 2 can still be modded. I just don’t get it.

Hi sanahas,

I’m not aware of the FW you have stated, the last one i know of is v01.11.01.50

This version is supposed to have an issue with transmission distances and the best FW is 1.08.1

From the FW version you’ve stated it looks like you have the X3 camera ?

I’ve downgraded my i1 v2 from 1.11.01.50 to 1.08 and the controllers from 1.7 to 1.6 successfully.

DJI have stopped you downgrading the FW 1.11 but it can be done without a problem.

Let me know if you need any help in doing so?

Regards

Stuart

Yes please I would like to know how you did it. Hopefully it will work on the version that I have on here.
Thank you!

It was version v1.8 on the craft I was trying to achieve and v1.6 on the remote it was after v1.8 the cut the transmission power
I managed to get it to v1.10 with a patch in it but could not it to recognise the gimble so just put it back to latest version

Hi @sanahas and @Grant.whb

Here’s what i did to roll back the firmware to V1.08.01 on my Inspire 1 v2 (T601)

First create a blank document in Notepad on you PC and save as WM610_FW_DEBUG.txt

Once you’ve done that delete the file extension i.e. .txt (that includes the dot before txt) on the notepad file you just created,

Windows will say are you sure etc and say ‘Yes’

Your file should be called WM610_FW_DEBUG

Place this file onto the root directory of the memory card you’re going to use to update the firmware, it doesnt matter if there is already data on it, but if you want to reformat first you can.

Now add the firmware Bin file you want to update (downgrade) your Inspire to i.e. V1.08.01.

Place the card into your camera and switch on the Inspire, it will go through the downgrade.

You can downgrade one FW at a time if you wish but i went from V1.11 to V1.08 in one go.

During the upgrade you should hear the ‘dah dah dah’ sound , it will down grade the camera first , then the motors, then the battery

Each motor led will flash in turn and the led will light up ‘Red’ one at a time, this is an indication that its working ok.

It will take about 30 mins, on the safe side i left mine on for about 50 mins , the dah dah dah sound had stopped by then.

I switched off the Inspire, then connected it up as normal

Controller, ipad and then the Inspire to check the firmware and it showed V1.08.01 in the DJIGo App.

Once i was happy with that i downgraded both controllers from V1.7 to V1.6 via the App

I had to rebind both controller afterwards but it was a simple job using the DJIGo app.

Let me know if you have any more question before or after youve started.

The above file you create is for the X3 NOT the X5 camera, if you have a Inspire 1 Pro with X5 camera let me know as the file you need to create is different but the procedure is the same.

If you need any firmware BIN files let me know as i have most of them too!!

Kind Regards

Stuart

5 Likes

Thank you so much, Stuart. :pray:
This is very detailed and helpful.

2 Likes

You’re welcome :sunglasses:

I did this procedure and everything seemed fine except I don’t get a success statement in the log. My firmware has gone to 1.8.1.00 and is now free of the + sign afterwards.

I too am trying to roll back my inspire 1v2 but cannot seem to get it to work. I keep getting a corrupt bin file in the log. Any chance you could send me the Bin files you used? Thank you!

@Shooter22015 safe/clean firmware can be downloaded from here: Dank Drone Downloader - Web App

@PingSpike okay, that’s where I downloaded them. I must be doing something wrong. I’ll dive back into it this evening and see if I can get it to work.

1 Like

Hi,
Do you still require the fw?

If so which camera as the files are different

@AboveAndBeyondMedia im not sure. Im using the files from dank drone downloader but none of them seem to want to work. I have the x3 camera