Inspire 1 with Osmo X3

Hi all new member here.

I have a perfectly good spare Inspire 1 without a camera. I also have 2x working Osmo X3’s

Ok so i know the Osmo X3 (all black) doesn’t work on the Inspire 1 or more accurately the gimbal doesn’t work.
The camera actually works but the image in DjiGo is upside down.

The Inspire X3 (white and black) works fine on the Osmo handle because DJI decided to make it work.

Aside from some minor differences the two cameras are pretty much identical so I’m sure the Osmo X3 could work on the Inspire 1 with the right firmware but DJI won’t allow it probably for marketing and sales reasons.

I’m wondering if I did a force update on the Inspire 1 with the Osmo X3 attached would it flash the X3 with Inspire X3 firmware or would the X3 just reject it’s part of the update.

Has anybody else thought about this or even tried it?


Only one way to find out :slight_smile:

After the firmware update has run you’ll find a txt file on the SD detailing the results of the update so you’ll be able to see if it took.

Don’t forget to force the update, if it sees the same firmware version on the card it’ll not attempt to install it. Apologies if you know all that already.

Welcome to Grey Arrows!

Yeah press and hold the pairing button while switching on.
There probably is only one way to find out, just thought I would ask first on the off chance somebody else already tried it.

1 Like

Please come back and let us know the result!

Curious now :slight_smile:

1 Like

Well, it didn’t work and nearly broke my Inspire LoL
Even with the force method it kept failing the update. I ended up renaming it a service name and tried the force update again and this time it seemed to start updating.
Then it suddenly stopped with no indication or recognisable beeps.
I left it a good while just in case then powered off and on again and got a continuous on off beep instead of the dji tone
It connected to the controller and ipad but reported main controller no comms to centre board
I thought I had broken it!
Tried another force update with the standard bin file and Inspire x3 and it failed. all the time its still doing this beep beep beep.
Tried again and just left it. After about 15 mins the beeps changed tone and stopped.
Turned on and off and it powered up normally
So I don’t think I’ll be trying that again!

1 Like

Thanks for the update @stuuk1

I can’t help thinking there are more than a couple of significant hardware differences then? :thinking:

There would appear to be unless it is somehow locked by DJI
Anyway its beyond my skill level to overcome.

Sorry to come late to the party. Just used Google to find an answer:

Which, sadly, is an emphatic NO!

Yes I have seen all of that but just wanted to try anyway.
I’m pretty sure DJI block this for sales/marketing reasons rather than anything fundamentally different with the cameras.

1 Like

If they were able to release a firmware which allowed the Inspire X3 to work on the Osmo handle I’m sure they could have done the same with an Osmo X3 on the Inspire.

1 Like

If you do find a firmware fix then please let me know. I can live with an u[side down image as I have an FPV camera on the Inspire nose. Does the gimbal not work at all or does it stabilise the camera but not respond to control commands?

The gimbal doesnt work at all but the camera works albeit with an upside down image

1 Like