Inspire 2 NFZ removal


#1

Hi everyone hope your all having a good week ?
Ok so I set about trying to remove NFZ from my i2 this isn’t so I can go near airports or prisons but so I can do my work if close to or inside a NFZ without being tied to DJI.
So I started off using NLD it worked great on my P4p so went ahead and started on the i2 well that’s the biggest head ache I’ve had since the weekend.
I have been through all the fw versions NLD list and everyone one says fw not recognised and doesn’t give me an option to turn off NFZ . So I was lucky enough to stumble upon this great group and was helped by starting to root way but alas I get stuck on another issue where it says no devices or emulators found . Has anyone come across this before ? As I’m really not winning the race here :joy:


#2

I’ve saw this issue some time ago on one of my previous Mavic Pros.

For whatever reason, my Windows desktop PC simply could not see the MP via the adb shell (yet connected fine via DJI Assistant). I don’t know if it was a firewall setting or what, but I gave up trying after a while and used adb on the Mac instead, which worked first time :man_shrugging:

Are you running ADB as Administrator on Windows?

Got a Mac/Linux pc you can use instead?

And if you fly with DJI GO or Pilot, don’t forget to remove NFZ from your apps too :wink:


How to root your DJI Mavic Pro, Phantom 4 and Inspire 2 using DUMLRacer and completely remove NFZ
#3

hi thanks for reply
can you point me in the direction of how to remove nfz from go app as ive hit a wall trying to find that information
thanks again for your response


#4

Try running in a virtual machine with a clean version of windows for starters.


#5

You need to use the deejayeye-modder tool kit for that mate: