Inspire 2 Slave Remote Constantly Beeping?

OK, I took the plunge and bought an Inspire 2 again, missed the last one.
Setup is Cendence controller and crystal sky as main, flight controller.
Inspire 2 controller as slave controller.
When I turn the slave controller on, all I get is a constant beeping and a red flashing light from the controller.
Quick check on Google, have tried stick Calibration as recommended, but it won’t calibrate.
Any thoughts

Well that’s fell on deaf ears…
Will have a stab at checking the inter web tomorrow while I’m off for you Mick

1 Like

Thanks Jeff.
Have tried upgrading via iPad and Go4 app but not recognised.
It does connect to aircraft and controls everything all ok, just continuously beeping and red light flashing.
Oh, have charged batteries as well, so not that one.
I don’t have DJI Assistant 2 with using iPad, not sure if you can download DJI Assistant to the Crystal Sky.
Appreciate any help, thanks

I’m on it :+1:

1 Like

Thanks Jeff

Our you could try turning it of and on again …

not finding anything on the inter-web


This one worries me

let me edit the fucking thing dave

Cheers Jeff @sparkman999
Appreciate you taking the time to reply and you don’t even have an Inspire 2.
I’ve put the RC on charge again, it it is showing 75% charge.
This looks like it may be the issue, not sure how to check what the fault is.

Thanks again mate

no problem
as i said on the phone have a laptop i use for dancing…sorry if you need to do any installs if you AIR isn’t up to it
just bell me

1 Like

Cheers Jeff
All sorted, was inconsistent firmware and then need to recalibrate sticks. Appreciate you taking the time to respond.

That’s what friends are for

Now I have this investment opportunity in Nigeria you may be interested in …

1 Like