Lift off fail.. first build

Hi all,

Built a new drone that I cannot get to stabilise off the ground and would appreciate some more experienced help.

With all the shortages for parts this is what I ended up with:

Frame: Impusle RC frame
FC: Matek F722-STD F7 Flight Controller With OSD, Baro
PDB: Matek FCHUB-6S with 184A Current Sensor PDB
ESC: 4x Spedix LS40 Slim 40A ESC (3-6S)
Motors: 4x iFlight XING 2207 2-6S 2750KV Unibell Motor
Props: 4x Ethix S3 5x3.1x3 Prop
Receiver: TBS Crossfire Micro Receiver V2 and a TBS Crossfire Immortal T V2 Antenna
Cam: Runcam Swift Mini 2
VTX: Matek 40CH VTX HV Video Transmitter with a Foxeer 3 lollipop RHCP
DJI Goggle V2 with BDI Digidapter and TBS Fusion
Controller Radiomaster TX16S
Batteries: Tattu R-Line V3.0 1550mAh 6S 120C LiPo Battery for main, but during testing to get it off the ground I’m using my existing 4s (GNB 1500mAh 4S 110C LiPo Battery).

Drone built, motors spinning in the right directions and idle fine. Firmware on FC, receiver, VTX and ESCs all updated. Successful connections with BLHeli32 and telemetry and the like seem to be working fine.

Everything seems great in betaflight. Receiver properly setup, bi-directional d-shot on ESCs working, with ESCs on DSHOT600.

I’ve limited the throttle to 50%, as on first test it went straight up! Even now with default PIDs and rates (minor tweaks to filter to try and solve issue) a small touch on the throttle jumps the quad.

If I’m super gentle with it, it gets about a meter off the ground before it starts rolling one way, and if I apply any more throttle the motors just stop. I basically have a bunny hopping drone that cannot actually take off. To watch it it’s as if one rotor (usually the front right) behaves eratically, but I cannot reproduce this on the bench no matter what I spin it up to so I’m convinced the FC is sending inappropriate signals. I’ve tried disabling/tweaking filters, airmode etc.

Suspect this is an ESC/betaflight configuration issue where my lack of experience is showing but have been faffing with it for hours and not getting anywhere. I don’t think I made it any easier for myself with the motors.

Any bright ideas or debug pathways? I just want to get down to the park :wink:

A video will help us to help you. And instead of limiting the throttle to 50%, try throttle expo. Say at around 1250

1 Like

Also what might help is printing all the betaflight settings. To see the config. In the “CLI” panel can you type “diff” and copy what prints.

1 Like

Basically yes, I do DUMP ALL then copy and paste it into a simple text file editor, such as Notepad. I put the date in the file name then I have a record of all the iterations I’ve tried.

2 Likes

Noted, sorry I should have probably done that before.

Here are a couple of quick vids on my latest test of settings, now I still have the throttle cut-off but also a yaw issue.

And here’s the BF diff:
# diff

# version
# Betaflight / STM32F7X2 (S7X2) 4.2.8 Feb 15 2021 / 12:10:35 (101738d8e) MSP API: 1.43
# config: manufacturer_id: MTKS, board_name: MATEKF722, version: f173f9bc, date: 2019-10-02T14:43:13Z

# start the command batch
batch start

board_name MATEKF722
manufacturer_id MTKS

# name: Astra

# feature
feature -AIRMODE
feature MOTOR_STOP

# beacon
beacon RX_LOST
beacon RX_SET

# serial
serial 4 8192 115200 57600 0 115200

# aux
aux 0 0 0 1700 2100 0 0
aux 1 1 1 900 1300 0 0
aux 2 2 1 1700 2100 0 0
aux 3 13 3 1700 2100 0 0
aux 4 36 3 1700 2100 0 0

# vtxtable
vtxtable bands 5
vtxtable channels 8
vtxtable band 1 BOSCAM_A A CUSTOM  5865 5845 5825 5805 5785 5765 5745 5725
vtxtable band 2 BOSCAM_B B CUSTOM  5733 5752 5771 5790 5809 5828 5847 5866
vtxtable band 3 BOSCAM_E E CUSTOM  5705 5685 5665 5645 5885 5905 5925 5945
vtxtable band 4 FATSHARK F CUSTOM  5740 5760 5780 5800 5820 5840 5860 5880
vtxtable band 5 RACEBAND R CUSTOM  5658 5695 5732 5769 5806 5843 5880 5917
vtxtable powerlevels 3
vtxtable powervalues 25 200 400
vtxtable powerlabels 25 200 500

# master
set gyro_lowpass2_hz = 375
set dyn_notch_width_percent = 0
set dyn_notch_q = 250
set dyn_notch_min_hz = 90
set dyn_notch_max_hz = 350
set dyn_lpf_gyro_min_hz = 300
set dyn_lpf_gyro_max_hz = 750
set acc_calibration = 24,-28,14,1
set min_check = 1010
set max_check = 1990
set serialrx_provider = CRSF
set blackbox_device = NONE
set dshot_idle_value = 200
set dshot_bidir = ON
set bat_capacity = 1500
set small_angle = 180
set pid_process_denom = 2
set osd_warn_link_quality = ON
set osd_vbat_pos = 2112
set osd_flymode_pos = 2074
set osd_craft_name_pos = 2060
set osd_altitude_pos = 2528
set osd_warnings_pos = 14793
set osd_avg_cell_voltage_pos = 2048
set vtx_band = 5
set vtx_power = 3
set gyro_1_align_yaw = 1800
set name = Astra

profile 0

# profile 0
set dyn_lpf_dterm_min_hz = 105
set dyn_lpf_dterm_max_hz = 255
set dterm_lowpass2_hz = 225
set anti_gravity_gain = 1000
set iterm_relax = OFF
set throttle_boost = 0
set d_pitch = 39
set d_roll = 36
set d_min_roll = 0
set d_min_pitch = 0

rateprofile 0

# rateprofile 0
set roll_expo = 94
set pitch_expo = 94
set roll_srate = 64
set pitch_srate = 64
set throttle_limit_type = SCALE
set throttle_limit_percent = 25

# end the command batch
batch end

Is your channel map correct? :thinking:

On the receiver tab of betaflight power up the radio and move the sticks, make sure all the stick movements move the correct channel bar.

Can you post a screenshot of the sensor tab please? With the gyro showing?
Also, in the setup tab, is the craft moving as expected with regards to yaw when you move it by hand?

1 Like

Is the FC orientated correctly ?

2 Likes

Yep, and I tweaked the radio so everything is on 1000 low, 1500 mid, 2000 precisely.

1 Like

Hmmm

1 Like

I believe so, arrow on top pointing toward the front/camera. Didn’t have to remap the motors either (I did have to reverse them in BLHeli though as originally they were spinning the wrong way.

1 Like

I do not remember setting this, I’ll look it up in the wiki now. Thanks all of you btw. I wasn’t expecting such quick and helpful support.

1 Like

Also it might be worth looking on the flight controllers manufacturer’s website for a default config dump file as if you’ve updated the firmware it may have lost its config. At least then you can reload the defaults :+1:t2:

1 Like


(circled is me moving drone manually)

setup page showing orientation working

1 Like

Blockquote Also it might be worth looking on the flight controllers manufacturer’s website for a default config dump file as if you’ve updated the firmware it may have lost its config. At least then you can reload the defaults :+1:t2:

this is a good point. In the config has the FC been flashed with the right settings? its showing: “# name: Astra”. I think you should be flashing “MATEKF722”

I named the drone Astra in the config after flashing, with full chip erase and allowing BF to apply defaults after reboot. Frankly I only did this for ease when backing up settings as it automatically puts the name in and prevents confusion with my other drones :smiley:

Couldn’t find one.
http://www.mateksys.com/?portfolio=f722-std

1 Like

I don’t suppose you could post a zip of a blackbox?

Stupid question but the props are definitely on the right way? It’s hard to tell in the vid

Good thought, I ordered a new SD card from Amazon arriving tomorrow for just this. Never used black-box but do love the thought of it, was one of the reasons I chose the FC but I stupidly assumed one of my larger SD cards would work and only became aware of my mistake this morning.

2 Likes