M2Z video not appearing in GO4 - help!

I no longer get video clips sent to DJI Go 4 when I take a video - this is annoying me. Have I changed a setting inadvertently?

I believe there’s a storage limit within the Go4 app. You may have to increase it.

1 Like

Keep an eye on the storage though,it can get quite big !!!

Coincidentally, I’ve been ignoring the same thing myself on the M2P for a while and finally decided to take a look at it yesterday. The settings are under ‘General Settings’.

Obviously, you need to have the ‘Cache during video shooting’ option set, which was already on by default. But it seems that the ‘clear cache automatically’ option defaults to off (or I’ve inadvertantly turned it off at some point). So I turned that back on.

The max capacity was also down at a lowly 4GB. When I swapped this to ‘Auto’ the available space jumped up to 13GB. I guess this is dependent on what available storage you actually have on your device.

Anyway, after fixing both of these I’m now back to recording the cache fine.

Hope that helps.

1 Like


Depending on which version of GO4 you’re using, the setting will look something like this:




1 Like

Perfect reply-timing @JoeC :rofl:

1 Like

And you :wink:

1 Like

But are we right? :thinking:

Or did we both get it wrong? :smiley:

1 Like

Nailed it guys! Many thanks for the help.


Excellent - thanks for letting us know :+1:t2: