Mavic Air 1 - main controller data error

Can anyone advise.

I have main controller data error in my screen which is stopping me from being able to calibrate my IMU and gimbal, along with the compass.

I have tried assistant 2 software update, but this not fixing the problem.
I don’t even think my drone updating properly. As in videos it says that after a update that drone should switch its self off. This is not happening.

Is it worth doing factory reset?.

What app are you using there.

DJI GO 4.

Why? Has things changed that much since I last flew my drone :grimacing:.

Not changed at all lol, most of the kids use litchi or FLYAPP nowadays. :joy:

found this…

if it helps?

Thank you for the video, but I will not be dismantling my drone.

If it needs this done to it, then DJI can do it.

Although I would be very disappointed if my drone needs new internal parts, as it has hardly been used and has sat in its bag for 18months in my house.

1 Like

So I tried downloading DJI FLY APP. The Mavic air 1 is not on this app.

The controller is still connecting to the drone, but I still have a main controller data issue warning.

I can’t get my controller to connect to the Assistant 2 program to update the software as its looks like it is not recognising to controller.

I can also get my phone to connect to the drone without the controller, but I still get my main controller data issue error.

The drone will take photos and videos when connected to the controller or my phone.

I am sure it’s a software issue some how.

Would another controller be able to connect onto my drone? Or another drone be able to connect onto controller?.

If you paired them together, yes.