Mavic Air 2 app not connecting to the RC

I’ve just been doing all the updates for my Mavic Air 2 all completed fine but now my Fly App won’t connect to the RC the RC is connected to the drone ok as I can start the props up by pulling the sticks in and down.

At first I thought it might be a failed RC Cable so I tried a different one same issue. I’m using a Samsung Galaxy S7 Edge. Fly App is fully up to date with the latest version.

Now heres the kicker I’ve tried it with my Samsung Galaxy s10 5G again with the latest version of the fly app and that is working just fine. Now again this is also a different RC cable as my s7 is micro usb and my s10 is usb C.

Has anybody had any similar issues? Everything was working fine before the updates.

I thought it might be the Micro USB port on the phone that’s at fault so I’ve just tried it with my Mavic Mini and that’s working just fine.

Do you have an OTG cable you can try with the S7 or connect to a PC and transfer some data both ways?

Delete that just read the second post. I think you need to delete the app and all associated data. Would it be a biggie to go into recovery and wipe the data? Delete the data and wipe the cache.

Bloody phones are great when working, bain off my working life (13 hairy arsed engineers doing their best to bugger a phone up to get a new one) when not.

I have tried completely removing the app and re installing it with no avail still won’t connect. It’s almost like the phone isn’t detecting the controller as it doesn’t even start charging the phone but when I connect my s10 that’s working fine starts charging and loads into the camera view just fine. It’s really odd.

Does your controller connect to the MA2 without a phone present?

Yeah, the controller and drone are linked just fine I can start and stop the props with no issues using the sticks on the controller with no phone attached.

Very odd.

Sorry can’t be of any help android isn’t my thing.

1 Like

Is the phone backed up to Gmail account?
If so I would wipe the phone completely from recovery mode and clear the cache.
Then restore from the cloud. You will lose some data though. Gmail back ups are not 100%

To be honest it’s my drone phone (my old phone that I kept after upgrade) so their isn’t any data on it its sole job is to run the DJI Fly app every thing else on the phone is already factory reset. I’m beginning to think I’ve just been unlucky and have 2 failed RC cables. The phone connects to my mavic mini just fine but not the Air 2. So that kinda rules out any issues with the phone.

Just as a test I have tried the RC cables on my FPV quads to attempt to use them as a data cable so I can connect to betaflight using the speedy bee app on my phone and that didn’t work either on both cables I have but to be honest I’d never tried doing that before so I don’t know if it worked before or not so I’m still non the wiser but I am leaning more towards it being an RC cable issue rather than the phone.

Order a OTG cable from Amazon, few quid, and put a USB stick in it. Transfer data back and forward to prove phone port.

Data passes through the port just fine as I can view the camera feed from my mavic mini.

I may try buying a new RC cable though.

Is it both ways though? Seems unlikely to be 2 cables. TBH it sounds like a software corruption that is stopping the Air 2 operating.

I’ve ordered a new RC Cable from Amazon it arrives tomorrow so I’ll update then :+1:t2:

Sounds like a cable issue to me mate. Think you’re on the right track :+1:t2:

1 Like

The new RC Cable has just been delivered and I can confirm that it was the RC Cables that was at fault.

Fitted the new cable and it’s now working fine. Damn flimsy cables :man_facepalming:t2:


Glad its sorted mate :+1: note to self buy spare cable to keep in my manbag


Yeah might be worth it :+1:t2: although the one I’ve brought is longer than the original and doesn’t fit in the controller as nice as the short one but oh well I can live with that :+1:t2:

1 Like

Glad it’s sorted. I bought a cable straight away because to me at least, it looked like it would get damaged being squashed into that controller space. Maybe one for the new mini 2 owners to learn from as well.