Mavic Pro Filter causing gimbal fault

Hi all,

I have some new filters to try but when I do the gimbal just hangs its head and will not move, without the filter it’s normal.

So I am thinking that the gimbal is very finally balanced and popping a small weight on the front is causing a problem, so what if I put a filter on the back of the gimbal as well? or a counter weight on the back it should be in balance?

I have searched about this problem and not found this idea, I’m thinking of a small weight would work fixed with a dab of silicon, but before I try has anyone tried balancing the gimbal?

Sounds like an excellent idea.

Which drone is this? Is there room to fit a counterweight?

I used to fit balance rings to the Inspire camera when using different lenses, for the very reason you mention here, so it’s not uncommon:

It is uncommon on smaller drones though.

Your other option might be higher quality, and lighter, filters.

I have a Mavic Pro

I don’t see why it would not work?

DJi sell them for some cameras, Buy Zenmuse X5S Balancing Ring - DJI Store

The best filters designed specifically for the MP are made by PolarPro, straight out of the box no need for balancing.

1 Like

I will have a look

With the lens on the gimbal reports an overload and stays with the camera pointing down 45deg it will no move, so I tried to balance it up with a weight in the back.

Are they original filters for the drone ? Have heard a few complaints about after market ones on drones before, causing gimbal problems,

Just a thought, when the drone is booted up & the gimbal has done its thing, is there plenty of resistance in the gimbal ? ( if that makes sense ) or possibly but hopefully not :crossed_fingers:t2:faulty / failing gimbal motor, no doubt you may have thought of that all ready.

It is strange when booted up I can fit the lens and all is well, it’s in the boot up program it fails ?

Hmm, does sound strange.

On a Mavic pro it is best to let it do the dance and then attach the filter

Hi all, today I managed to lend some very good scales and weighed the NT8 lens 1.1g so I made a counter weight of 1g for the rear of the gimbal the counter weight was a bit lighter to allow for the glue I used, fitted the lens and counter weight, the Mavic Pro spit it’s dummy out “large load on gimbal”

I removed the lens and started it up again with the weight still on the back but no lens, all fine so I did a gimbal reset 100% fine with the weight on?? what’s going on? could the darker lens be telling the software there is a problem? If I put the lens on after it boots up and says ready to go, all is fine and I can do a gimbal reset with both on? But this is a messy way of using a NT lens having to put it on after start up?

I don’t know what to do next! I just don’t understand the gimbals requirements!!

I’ve just read through this topic a few times & can’t see anything as to why you was

What is the reason why you was doing this if you don’t mind me asking ? Have I missed something in this post ?

What are you trying to achieve :+1:t2:

Ah I see there’s another thread / topic on this.

@johsen I’ve moved your post over here, to the correct thread :slight_smile:

1 Like

When I bought my Mavic back in the day, I bought Freewell ND filters which caused the gimbal to fail on start up, finally after trying to mount the filter on a cold frosty morning only for it to keep failing, I stopped and thought about why the gimbal failed.

Tech: the gimbal is made up of coils which are basically Transformers which work via magnetic field flux density. The gimbal is engineered to a very high tolerance to calculated Amperage against weight in grams / magnetic flux.

Adding any weight especially on start up, gimbal self calibration reports an over Amperage and thus fails but if after calibration the filter is added it doesn’t see this because the gimbal enters state 2 which allows for a high current to offset buffeting by wind in flight.

After I bought the PolarPro filters which I still have as I’ve still got my Mavic Pro, I’ve never looked back…

Save you sanity go PolarPro… :wink:

Many years ago … early '17 ish … the initial filters I got for my MP (Y&C) caused errors.

I changed them (FOC … Hobbymounts saw the problem and agreed it wasn’t correct) for another make (Freewell) and all was well.

Might be worth checking to see if the ND Filter is causing a physical problem by jamming the gimbal somewhere in its calibration (bootup) sequence, which moves the gimbal out to its limits - not something that often happens once you get it airborne and start using it.
First thing to try is pick the drone up, hold it horizontal, and power it up with the filter attached. The Mavic Pro sits very close to the ground pre-takeoff, and the gimbal might be being obstructed.

thank’s for your reply @Wintermute I have it clear of the ground but something is different in the boot up program and the gimbal self Calibration. I could have a gimbal that is too springy can you get new rubbers for the gimbal?

I think I under stand what is wrong now, I read a post about the problem of gimbal overload. I now believe my problem is the Gimbal Vibration Absorbing Board, mine seem to be weak, the front allow the gimbal to hang low enough to constantly sit on the front restraint it’s polishing it!
To check yours set the drone on top of a door so with a torch you can see up at the board and the rubbers. A new one is ordered only £7.06 delivered! In the picture the one on the right is stretched?