Mavic Pro stopped recognising memory card

My Mavic Pro has stopped recognising the SanDisk Ultra 64GB microSD.

It recorded onto it just fine a few days back, but now does recognise the fact that it is inserted. I have done a full format on the PC, but to no avail.

Has anybody experienced a similar occurrence, or have suggestions as to how to overcome the issue?


Have you tried to reformat in the MP?
If it was formatted elsewhere, it sometimes gets awkward about things.

1 Like

I can’t reformat it in the MP, because the MP does not recognise that it has a card inserted!

2018 Treasure Hunt Winner - Gold

    November 1

I have done a full format on the PC, but to no avail.

Have you tried to reformat in the MP?

If it was formatted elsewhere, it sometimes gets awkward about things.

Mine didn’t recognise my card once (it had been reformatted on my phone OTG card reader), but when I went to the format option it still managed to format it.

I’d try another card to see if the problem persists.

I have actually tried re-formatting in the MP - but it simply says “no card found” (or words to that effect).

1 Like

Try this, I did it on a USB Stick that was being a bitch, and it worked !.

Make sure you know what your SD Cards drive letter/number is !, or you will format another drive unknowingly !.

The MP is exFAT?

1 Like

correct, forgot about that !

Either it should read … but ALWAYS reformat IN the MP before using.

I’ve had to do this before @northernlights53:

Granted, the cards I had issues with came from a Raspberry Pi, but the principal is the same.

#1 is worth a shot :+1:

Thanks for that - however it formats just fine in the PC - it’s the MP that’s having the problem!

Do you have another card to try? I think you need to define where the problem is: that specific card or a reader issue within the drone (such as a failed connection pin)


Got one arriving today - hopefully that will enable me to pinpoint the source of the problem.


So, I was advised that formatting the SD under Windows 10 means that the drone probably can’t read it - anybody else got personal experience of this?

Also, the brand new, fresh out of the box SanDisk Extreme Pro is also not recognised by the drone, so I’m thinking that it’s probably not the SD cards, but the six month old drone.

Any thoughts as to the next step?

Sorry to hear that. Might be worth inspecting the card slot on the drone in case any debris has found its way in there. Use a blower brush if you have one. It’s a long shot though. Otherwise a warranty repair surely.

Ok so same on 2 different cards…

I’ve read of people having same issue, multiple cards with no sd error and no option to format. Solution seemed to be use a different USB cable between controller and device.
Not sure how that would fix it but worth a shot.

Failing that start with a firmware refresh with DJI Assistant 2 and wouldn’t hurt to delete and reinstall GO4 app just incase.

I agree, definately worth a firmware refresh

It might be that the card reader slot has come adrift from the circuit board. Rick at DroneValley had an issue with the binding button (for pairing the remote) coming loose from its very lightly soldered joints. See video here:

1 Like

Hi - bit of a long-shot but I wondered if you have solved your problem with the SD card. I am a novice - just got a Mavic Pro second hand and have this problem. I am wondering if I have been sold a dud or if it is something I am doing wrong. Your thread just stopped so I guess you either fixed the problem or gave up on it! Hope you are still looking here and can answer. Thanks