Mini 2 Battery Firmware Fails

Has anyone else had this?

Fly app gives a popup for battery firmware update, I click update and it shows at 70% progress immediately then after around 30 secs I get an update failed message.

I have three batteries, one does not give an update prompt, both of the others do the above.
DJI suggest sending the two back for assessment but if its a quick fix I’d rather not lose 60% of my duration for however long it takes.

BTW no swelling or defamation.

It was covered in the Mini 2 firmware thread

Try this to refresh the firmware


Thanks, doesn’t help much as I am using a Mac but at least I know its a thing and not me being dim.

Drone hacks software allows for firmware refresh

Interesting, so I would downgrade the drone firmware and this should allow the battery firmware upgrade in theory?

Yes try that or reinstall the latest/ refresh

Good idea sadly the Mini 2 doesn’t want to connect to the app.

Power it up with the battery :wink: connect the usb to the drone only and when you hear the chimes then connect to the pc

I already tried that, I’ll give it another go but not hopeful. Really appreciate your help though.


This gets stranger by the minute. Previously deleted the Fly app on my phone, loaded an older version all to no avail. Then updated the Fly app again, tried to load the battery firmware on one of the batteries and it worked! The third battery is still failing to update - very weird.

Wrong, it didn’t update at all. Just decided to tell me that their were no firmware updates. Just restarted from scratch with the same battery and it still wants an update.

Don’t know what to suggest next!
I always uninstall the app and reinstall the newer versions rather than updating

Maybe you could get hold of a windows pc/laptop and try the tricks I have shown you

Where are you based? maybe someone local could help

Appreciate your efforts. I can get my hands on a Win 10 laptop. Just to clarify once the ini file is modified what is the procedure?

Connect drone after boot sequence, downgrade firmware for drone then attempt to upgrade the battery firmware or the drone firmware?

Should this be done via the software or the android app?


Thats ok, its good to help!

I would try just refreshing the current drone firmware first after modifying the ini file

Then connect to the controller and the App as the battery firmware can only be done with the app

1 Like

Thankfully it worked. Took a while to get Assistant to see the Mini 2 though. Had to change the USB cable which seemed to do the trick. Once again thank you.

1 Like

Excellent glad it worked, did you use a windows pc?

Yes, dug an old one out, bit of a hassle but less so than sending the batteries away :+1:

1 Like