Mini 2 / DJI Fly video freezes mid flight (iOS)

On a number of occasions, while flying my Mini 2, the FPV video on my phone just freezes. This happens when the drone is only 50 m away.
The telemetry information is still updated, so can fly the drone back etc.but even when the drone is only a few metres away, the video does not ‘come back’.

The only way I have found to get it back to life is to close the app, and re-launch it.
Is this a known problem? Does anyone know of a cure / way to stop it occurring?

Thanks all :slight_smile:

I’m using a 12 Pro Max with my Mini 2, never had this issue. Which iPhone/iPad are you using?

1 Like

It’s an iPhone 12 ‘standard’.
The fault is very intermittent. I have flown it for an hour this morning (3 batteries), and it never happened once.
I can’t identify anything that triggers it … its seems completely random

Check/change the cable between the phone and the controller.

1 Like

I had a similar issue with mine, carefully cleaned out the charger port ( you’ll be surprised how much muck and fluff gets in there) and problem solved

Had the same problem once myself and did exactly the same with my Android Galaxy S6, when I had the Mini 2… Such a simple fix. No need to go buying a new cable, just check all connectors and sockets are clean. DO NOT USE LIQUIDS by the way… I got some cleaning pads, (FOAM) and it came with dozens of pointy foam sticks, similar to cotton buds, just using one of these, I was shocked by how filthy it was in there…

I had the same issue with the iPhone X on IOS 14.8. Updated to 15.6 and not had the issue since.

Thanks all … stupidly, it never occurred to me that the FPV video was coming through that cable.
Next time it happens I can do a bit more fault finding (I will clean out the port anyway!)
Thanks for the assistance :smile:

So as a further update …. The fault happened again twice this morning.
As fault finding steps, I tried:

  • disconnect and reconnect the iPhone cable (from each end in turn)
  • powered down the drone (actually changed the battery) and powered back on
    Neither of these had any effect, as soon as it was reconnected/powered on, the frozen video was on screen (I did notice the histogram and the compass were both updating as normal.
    The only thing that seemed to fix it was to quit the app (and close it fully) and restart.

I’m at a loss of what do try next … anyone had any experience of this (iOS 15.6 with 15GB available)

Do you have access to another iPhone or iPad? If you can test another device you can at least then rule your device out (or in!) which will halve your issue-hunting instantly.

Uninstall the app. Clear the data and cache, soft reset your phone, and reinstall the app.

Or try a different cable altogether

Thanks … I’ll give that a go! :thinking:

Also make sure all other apps are forced closed, just have the DJI app running

And put the phone in airplane mode

I misread that as “put the plane in airplane mode” which I suppose is what we do with the drone every flight :slightly_smiling_face: