Mini 3 Pro - Unable to use remote controller SD card

Has anyone else had the below message appear on their RC Controller following one of the many recent firmware updates?

Unable to use remote controller SD card.
Remote controller SD card speed low. Unable to use. Use a highsp…

The SD card is a new SandDisk Extreme Pro U3 V30 128GB and was working fine up until last week.

Does anyone have any suggestions or do I just have a dud card?

Have you tried another card?

Is it possible you have a fake card?

Format it in the control and try again ?

There’s no option to format the card in the controller as it is not recognising it at all. I’ll try to format on PC and see if that works. Thanks.

I have ditched the packaging so not really able to tell whether it’s fake or not. It was working fine until last week.

Random thought …

I’m assuming, since it’s “modern”, that it’s supposed to accept >32GB cards … and that it’s not an exFAT v FAT32 issue?


Cancel that! The DJI Specs page gives the following as Recommended microSD Cards for the DJI - RC

SanDisk Extreme 64GB V30 A1 microSDXC
SanDisk Extreme 128GB V30 A2 microSDXC
SanDisk Extreme 256GB V30 A2 microSDXC
SanDisk Extreme 512GB V30 A2 microSDXC
SanDisk Extreme Pro 64GB V30 A2 microSDXC
SanDisk Extreme Pro 256GB V30 A2 microSDXC
SanDisk Extreme Pro 400GB V30 A2 microSDXC
SanDisk High Endurance 64GB V30 microSDXC
SanDisk High Endurance 256GB V30 microSDXC
Kingston Canvas Go!Plus 64GB V30 A2 microSDXC
Kingston Canvas Go!Plus 256GB V30 A2 microSDXC
Lexar High Endurance 64GB V30 microSDXC
Lexar High Endurance 128GB V30 microSDXC
Lexar 633x 256GB V30 A1 microSDXC
Lexar 1066x 64GB V30 A2 microSDXC
Samsung EVO Plus 512GB microSDXC

Thanks, I bought based on this list from Amazon. I’ll have a play later at formatting and see how I get on.

My understanding is that this message was after one of the RC upgrades which I believe is to help stop the RC freezing issue. You now need a fast enough card. That Sandisk card meets the spec fine. It is possible, as has been suggested, that card could be fake as they are often counterfeited due to having a well known name. I have never had an issue with cards from Amazon direct. I would be more wary about unknown 3rd party vendors in the marketplace

1 Like

If you have an RCN1 put the SD Card in the drone. Connect to the drone with the RCN1 controller and re-format the card in the drone.
Turn off the drone and put the card in the rc controller. Reconnect the RC controller with the drone and see if it is recognised. I had to do this with mine and it sorted out the problem.

Hope this helps.

1 Like

actually there is a way to format it in the controller :slight_smile: pull menu down the very top right cog bit into settings then find storage tthen see card under itt will say format :slight_smile:

1 Like

Thanks for the suggestion. I tried this, but because the card is not recognised it is not shown in the menu.

Thanks for this. I have the new RC Controller, but I tried it anyway in case there was some kind of auto-format when a PC-formatted SD card is put into the drone. Alas, no luck. I assume I have picked up a fake on Amazon, or it is just a dud. I’ve never had any issue before, and to be fair, it writes ok via an adaptor on my PC, so not sure what’s going on here. Maybe it’s a fake that can’t achieve the stated write speeds needed by DJI but works ok for normal use. Then again, it worked ok in the controller with no error messages a few weeks back, which led me to think it might be a firmware issue that others might be experiencing. Weird.

Thanks, Pete, I think this may be the cause, and I’ve picked up a fake on Amazon.

Confirm , other cards i.e the drone one work ok in the controller ?

1 Like

Send it back to Amazon if faulty.

You do not need the original packaging.